[MonoDevelop] How do I debug Monodevelop?

cmdematos cmdematos at gmail.com
Mon Sep 5 18:43:54 EDT 2011

I have the latest git-source mono an monodevelop happily running in Ubuntu. I
have followed the articles and created a development environment where I
hope to build some addins for Monodevelop.

I am trying to get the latest castleproject running, and no I have no
interest in just using the DLL's. I want full control, and should be able to
compile this from source.

The castle projects csproj files target framework v4, profile client. Our
Monodevelop IDE does not have profiles, it only has runtimes. First I tried
changing the MonoDevelop.Core.Assemblies.TargetFrameworkMoniker.cs Equals
method to not compare using profiles, but this proved insufficient. The
castleproject project opens up OK if I delete the TargetProfile entry so I
know that targeting the comparison (or something like it) should be

I next tried to load Monodevelop into monodevelop (following Article
instructions) and opened the Main.sln project.  This brings errors that the
gtk-gui generated sources are attempting to set private fields. 

What is the procedure for using monodevelop to debug/build monodevelop? The
articles are not clear enough on this. Can someone who actively develops on
monodevelop please provide some pointers here.

Many thanks in advance...

View this message in context: http://mono.1490590.n4.nabble.com/How-do-I-debug-Monodevelop-tp3792268p3792268.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list