[MonoDevelop] Building MonoDevelop on the kubuntu 11.04

jmalcolm malcolm.justin at gmail.com
Sun May 8 12:23:19 EDT 2011

I think you have to have a version of gmcs installed already to compile from

Try 'apt-get install mono-gmcs' before you build.

You can do 'apt-get remove' between 'make' and 'make install' to restore
your system to a pre-Mono state before installing your git build.

mihir786 wrote:
> Hello,
> I just clone the source code repository from github and i tried to install
> but i am getting following error while configuring
> Configuring package: main
> -------------------------
> Configuration options: 
> Running aclocal  ...
> Running automake --foreign  ...
> Running autoconf ...
> Running ./configure --enable-maintainer-mode --enable-compile-warnings
> --prefix=/opt/mono ...
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking for a thread-safe mkdir -p... /bin/mkdir -p
> checking for gawk... gawk
> checking whether make sets $(MAKE)... yes
> checking how to create a ustar tar archive... gnutar
> checking whether to enable maintainer-specific portions of Makefiles...
> yes
> checking for mono... /usr/bin/mono
> checking for gmcs... /usr/bin/gmcs
> checking for update-mime-database... /usr/bin/update-mime-database
> checking for pkg-config... /usr/bin/pkg-config
> checking for msgfmt... /usr/bin/msgfmt
> checking for msgmerge... /usr/bin/msgmerge
> ./configure: line 2704: syntax error near unexpected token
> ./configure: line 2704:
> $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)'
> I also tried to follow the steps given in below link
> http://www.mono-project.com/Parallel_Mono_Environments
> Please tell me the solution

View this message in context: http://mono.1490590.n4.nabble.com/Building-MonoDevelop-on-the-kubuntu-11-04-tp3505101p3507269.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list