[MonoDevelop] Satellite Assemblies. Where is 'al2' for MonoDevelop on Windows 7?

Wayne Walter waynewalter at tickzoom.com
Mon Mar 14 12:38:29 EDT 2011

Oh, another thing I tried was removing the "de" culture resource file from
the project and try
building that way. It simply gave the same error regarding the "es" culture.
So I went down
the line and it gave the same error for all of them until there were none
more. Then it completed
successfully but when running the GUI, there was a runtime error due to
missing the satellite

So again, that seems more evidence that it's the "al2" missing. I searched
for it, where does
MonoDevelop expect to find it?  There isn't one inside the MonoDevelop bin

- Hide quoted text -

On Mon, Mar 14, 2011 at 11:05 AM, Wayne Walter
<waynewalter at tickzoom.com> wrote:

    Thanks for a reply. Well, w/o changing anything, I can open the solution
in Visual Studio
    and it correctly creates the resource assembly including German
resources for the 'de' culture.

    So it "seems" still to be the al2 which is not found.   Otherwise, could
it be a difference
    in how to configure satellite assemblies in MonoDevelop vs. Visual

    But googling this made it appear the MonoDevelop does satellite
assemblies the same as VS 2008.

    However, frankly, I'm very new to satellite assemblies so that puts me
at a disadvantage. My expertise
    lies in "back end" or server-side software rather than GUI interfaces.


    On Mon, Mar 14, 2011 at 10:21 AM, jmalcolm
<malcolm.justin at gmail.com> wrote:

        Is it possible that the file it cannot find is the 'de' culture and
not al2?

        Wayne Walter wrote:
        > Versions:
        >   Windows 7, 64 bit
        >   MonoDevelop
        >   Mono 2.6.7
        > MonoDevelop is cool. We successfully ported from .Net and passed
all unit
        > tests on one of the solutions. In the other solution we include
        > project which has a satellite assembly of resources files for
        > languages.
        > But the build fails saying:
        >    Generating satellite assembly for 'de' culture with al2
        >    Error while trying to invoke 'al2' to generate satellite
assembly for
        > 'de' culture:
        >     The system cannot find the file specified
        > Why is that?  Where is the al2 linker?
        > After installing the entire Mono 2.6.7, here is an al2 in the Mono
        > 2.6.7/bin folder.  So we restarted MonoDevelop, but it still gives
        > same error.
        > How to resolve this please? We're very excited by the promise of
        > cross-platform ability of MonoDevelop and will be happy to
contribute $$$
        > once this proof of concept succeeds.
        > Sincerely,
        > Wayne

View this message in context: http://mono.1490590.n4.nabble.com/Satellite-Assemblies-Where-is-al2-for-MonoDevelop-on-Windows-7-tp3353875p3354334.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list