[MonoDevelop] libs not found when using MonoDevelop

Christian Manthey info at manthey-it.de
Fri Feb 18 04:53:54 EST 2011


i have a C# project that is mainly developed in VS2010.
The project is build up using a MVC concept and when porting the project to
support MAC i created a second GUI based on GTK# (next to Windows.Forms).

My problem is now, that when i start the project from MonoDevelop (2.4.2) on
Mac and try to debug from there, it does not find the required libs to even
pass the GTK.Application.lnit() function.
This worked before (some month ago) but i can't remember since when it does
not work anymore (maybe since i upgraded from VS2008 to VS2010...)

When starting it from my .app configured Mac application the application
runs fine.
I started MonoDevelop with LogLevel Debug and could see that the application
is only looking into the source directory for libs and not under

When creating a new empty GTK# application on the Mac MonoDevelop it is
possible to debug and run the app without a problem.

So i guess that some project specific configuration is not set correctly.

I tried to compare the project settings of my existing and of a new app but
couldn't find any visible differences.

Does anyone have a hint where the error in my setting is?

Kind regards,

More information about the Monodevelop-list mailing list