[MonoDevelop] MonoDevelop problem on Windows

John Bonnett jbonnett at internode.on.net
Mon Feb 7 04:02:00 EST 2011

On 6/02/2011 5:43 AM, Michael Hutchinson wrote:
> On Fri, Jan 28, 2011 at 6:19 AM, John Bonnett<jbonnett at internode.on.net>  wrote:
>> I have installed MD v2.4.2.1 on Windows  and when I run it I get to the
>> start screen and then I get this message
>> System.MissingMethodException: Method not found: 'Void
>> Monodoc.RootTree.AddSource(System.String)'.
>>     at MonoDevelop.Projects.HelpService.InitializeHelpTree()
>>     at MonoDevelop.Projects.HelpService.<AsyncInitialize>b__0(Object )
>>     at System.Threading._ThreadPoolWaitCallback.WaitCallback_Context(Object
>> state)
>>     at System.Threading.ExecutionContext.Run(ExecutionContext
>> executionContext, ContextCallback callback, Object state)
>>     at
>> System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback
>> tpWaitCallBack)
>>     at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object
>> state)
>> and MD closes down. I did install the pre-requisite GTK# for .NET 2.12.10
>> after uninstalling a previous version (2.12.9 I think).
> It looks like MonoDevelop has an out of date monodoc.dll. Not sure how
> that happened, as the installer seemed to work fine on the machine I
> tried. Could you uninstall MD, check the installation directory is
> empty, then install it again?
Thank you for your reply. I did indeed have an old monodoc.dll. It was 
in the MonoLibraries package and uninstalling that plus cleaning out the 
installation folder and reinstalling fixed the problem.

Thanks for your help.

John Bonnett

More information about the Monodevelop-list mailing list