[MonoDevelop] Fwd: Re: Fwd: nunit Problem in MonoDevelop 2.6

Jim Orcheson jim at va3hj.ca
Sun Dec 11 06:44:49 EST 2011

Hi Ian,

As noted below, MonoDevelop shows nunit 2.5.10. Yes it was necessary to
change from nunit whatever to the nunit 2.5.10 package just to get the
tests to build, but my problem comes when I try to run the tests.

I actually have two nunit packages listed when I edit the references for
the project. One is nunit and the other is mono-nunit. I have tried both
with the same result.


On 11-12-10 09:20 AM, Ian Norton wrote:
>  Hello
>  I had some strange problems too, I replaced the 2.4 nunit DLL that comes as part of monodevelop with the 2.5 ones manually as there is no way to configure a different one, it works for me now.
>  Ian
>  -- I may have used dictation software to write this email, please
>  excuse any confusing mistakes. Jim Orcheson<jim at va3hj.ca>  wrote:
>>  >I posted this message a few days ago but no one answered, so I am
>>  >posting again. It is obviously rather hard to unit test when unit
>>  >testing with MonoDevelop is broken on my system.
>>  >
>>  >
>>  >I created a solution that included a set of nunit tests on Ubuntu 11.04
>>  >(MonoDevelop 2.4.X, mono 2.6.7, and some version of nunit). There were
>>  >no problems.
>>  >
>>  >When I upgraded to Ubuntu 11.10, (MonoDevelop 2.6, mono 2.10.5, and
>>  >nunit 2.5.10) I had the usual teething problems but eventually got
>>  >everything to build. However, when I attempt to run any of the unit
>>  >tests, I get the following in MonoDevelop:
>>  >
>>  >Test Results for MyTests configuration Debug|x86
>>  >Internal Error
>>  >        NullReferenceException: Object reference not set to an instance of
>>  >an object
>>  >        Stack Trace
>>  >            at
>>  >System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(System.Runtime.Proxies.RealProxy
>>  >rp,
>>  >                        IMessage msg, System.Exception&    &exc,
>>  >System.Object[]&    out_args) [0x00000] in
>>  ><filename unknown>:0
>>  >
>>  >This message is so useful (not) that I have no idea where to even start
>>  >determining what has gone wrong. Can anybody point me to what is
>>  >missing?
>>  >
>>  >Thanks,
>>  >
>>  >Jim
>>  >

More information about the Monodevelop-list mailing list