[MonoDevelop] Can't Run/Debug. Huh?

Tess Snider this at malkyne.org
Wed Sep 29 16:20:05 EDT 2010

On Wed, Sep 29, 2010 at 4:43 AM, Levi Bard
<taktaktaktaktaktaktaktaktaktak at gmail.com> wrote:
> Are you running the version of MonoDevelop that shipped with Unity
> 3.0? Or with one of the older beta/preview releases?
> Or have you installed the Unity debugger addin from source?

You know, funny you should ask that...

I kept wondering why that was still there.  See, I have two parallel
installations of MonoDevelop -- one of them in my Unity directory
tree.  At one point in the past, I experimented with the Unity
Debugger plugin on my main MonoDevelop, instead of the one over in the
Unity directory.  However, it wasn't doing what I wanted, so I went
back to keeping them separate.  However, the Unity Debugger add-in had
hung around, even when I re-installed MonoDevelop, because
uninstalling MonoDevelop does not remove the AddIns directory.  I had
*suspected* that add-in might be causing my problems, a couple of
weeks ago, and I had tried disabling it, at the time, but it didn't
fix the problem.

So, finally, I uninstalled MonoDevelop, blew away the entire
directory, re-installed MonoDevelop, and now it works fine.  Huh.

Now, if only I could figure out why my friend can't run/debug on his Mac... :-D


More information about the Monodevelop-list mailing list