[MonoDevelop] HELP no gtk widgets showing up in toolbox

Michael Hutchinson m.j.hutchinson at gmail.com
Mon Jan 11 00:48:14 EST 2010

On Thu, Jan 7, 2010 at 8:02 AM, IrishBouzouki <jjmurphy at shentel.net> wrote:
> I do not have any GTK# widgets showing up in my toolbox when I open a form in
> the form designer.
> Just to be sure I followed the steps in one of the tutorials.
> I originally installed MonoDevelop with my Fedora-12 DVD install. It missed
> a few packages that perhaps are not technically considered dependencies (ie
> gtk-sharp*) but I picked these up with yum later. Since that may have done
> something out of order I tried re-installing all the packages in the order
> (1) mono-add*, (2) gtk-sharp*, (3) monodoc*, (4) monodevelop*. However this
> did not alleviate the issue.
> Perhaps I am still missing a required package for the widgets or perhaps I
> need some IDE setting?
> Since this is likely a Fedora-specific (and in fact likely a me-specific)
> problem I had tried asking about this on the Fedora Forums specifically but
> it failed to be noticed by anyone there who could help.
> Thanks, here is some install info...
> # rpm -qa |grep monodevelop
> monodevelop-2.1.0-4.fc12.x86_64
> monodevelop-devel-2.1.0-4.fc12.x86_64

MonoDevelop 2.1.0 is an old unstable/beta release. Fedora seems to
have a bad habit of shipping outdated unstable packages of MD - this
happened with 1.9.1 too IIRC. This might also be something to do with
Fedora's Mono packaging, which deliberately moves CIL binaries to
/usr/lib64, breaking the layout that apps such a MD expect. We haven't
had any success persuading them to change this.

I suggest you build MD from source (please read
http://mjhutchinson.com/journal/2007/11/08/how_not_break_mono and
http://www.mono-project.com/Parallel_Mono_Environments first!) and if
it's still a problem, file a bug.

Michael Hutchinson

More information about the Monodevelop-list mailing list