[MonoDevelop] MonoDevelop + Moonlight

Jake Moe jakesaddress at gmail.com
Thu Aug 19 17:55:27 EDT 2010

 On 20/08/10 02:32, Michael Hutchinson wrote:
> On Thu, Aug 19, 2010 at 5:58 AM, Jake Moe <jakesaddress at gmail.com> wrote:
>>  Hello all
>> Can anyone help me with this combo?  I've installed MonoDevelop v2.4,
>> and it runs, but when I tell it to make a test Moonlight app and try to
>> build/run it, it errors with "Framework 'Moonlight / Silverlight 2.0'
>> not installed", and if I expand all the References in the "Solution"
>> section, I get a bunch of "Assembly not available for Moonlight /
>> Silverlight 2.0 (in Mono 2.6.4)" messages, one under each reference.
>> Any ideas how to fix this?
>> I have the Moonlight plug-in installed from
>> http://www.go-mono.com/moonlight/, and it works on a Silverlight app I
>> wrote using Visual Studio & Silverlight in Windows.  Do I need it to be
>> in a system-wide location, and not just in my user profile?
>> Or maybe I need to install a "Moonlight SDK"?  I tried to find one of
>> these, but from what I gathered, this should have been bundled together
>> with the MonoDevelop sources, and I assume would have gotten built along
>> with it?  The availability of the choice "Moonlight application" in
>> MonoDevelop leads me to believe that it's built whatever it needs, but
>> I'm missing something.
>> I've also tried loading the VS 2008 solution I wrote (and successfully
>> built, and can successfully run on this system) into MonoDevelop, and
>> then I get the same errors I got before.
>> Documentation on the Mono, Moonlight and MonoDevelop pages is pretty
>> sparse when it comes to this combo; I'm getting the impression what I'd
>> like to do is very much under development, and perhaps just not ready
>> yet?  Or am I missing something?
>> Relevant info that I can think of that would be helpful is:
>> jmoe at aus8617 ~ $ uname -a
>> Linux aus8617 2.6.34-gentoo-r1 #5 SMP PREEMPT Thu Jul 22 11:29:35 Local
>> time zone must be set-- i686 Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz
>> GenuineIntel GNU/Linux
>> jmoe at aus8617 ~ $ gcc --version
>> gcc (Gentoo 4.4.3-r2 p1.2) 4.4.3
>> Copyright (C) 2010 Free Software Foundation, Inc.
>> This is free software; see the source for copying conditions.  There is NO
>> jmoe at aus8617 ~ $ mono --version
>> Mono JIT compiler version 2.6.4 (tarball Tue Aug 17 19:07:25 EST 2010)
>> Copyright (C) 2002-2010 Novell, Inc and Contributors. www.mono-project.com
>>        TLS:           __thread
>>        GC:            Included Boehm (with typed GC and Parallel Mark)
>>        SIGSEGV:       altstack
>>        Notifications: epoll
>>        Architecture:  x86
>>        Disabled:      none
>> jmoe at aus8617 ~ $
>> Mono has been built with the "moonlight" use-flag enabled, which says it
>> will "Generate Moonlight 2.1 assemblies".
>> If you need any further info, let me know.  Any help would be
>> appreciated.  Thanks.
> You need to install the Moonlight SDK packages - the plugin is not
> sufficient. The Moonlight SDK is not part of MonoDevelop - it's only
> bundled with MD on Mac. On Linux distros you should get it from
> packages.  However, I don't know if they're available for your distro.
> You might find the following link useful:
> http://mjhutchinson.com/journal/2009/05/08/moonlight_development_linux_monodevelop#comment-715
Excellent!  Thanks for that, it worked a treat.  I had a feeling I was
missing the SDK, I just couldn't find it.  Gentoo doesn't appear to have
the Moonlight SDK available, but extracting it from the MacOSX download
worked without a hitch.  I've now successfully compiled the base
("test"?) Moonlight app that gets created by MonoDevelop and it opens in
a browser.

Thanks again for the info.

Jake Moe

More information about the Monodevelop-list mailing list