[MonoDevelop] Mono and running Unix commands

Jacek Rużyczka stacheldraht at interia.pl
Fri Apr 2 12:55:17 EDT 2010

Am Freitag 02 April 2010 18:19:23 schrieb Mark Devgood:
> So as test I assigned 'chmod 777 Parent_Dir_Name' to the directory where I
> want my mono website to create files (under apache), and it looks like it
> worked!
> However, the new file the website created had the following ownership:
> -rw------- 1 nobody nobody 7385 Apr  2 11:40 test.xml
Of course this will not work: When you assign permissions to a dir by using 
the chmod command and then create files inside this dir, then *normally* the 
files will get the same permission structure as the dir.

However, when using File.Create out of an ASP.NET solution, the rules of the 
container (= Web server incl. .NET module) apply...and these rules are 
extremely strict in order not to compromise the security of the Web server.

Maybe a look into the Apache / mod_mono doc can give you a clue which config 
files must be altered to get your problem solved.


Sprawdz pogode na Swieta.
Kliknij >>> http://link.interia.pl/f265a

More information about the Monodevelop-list mailing list