[MonoDevelop] Integregrated Help Viewer

Edward Diener eldlistmailingz at tropicsoft.com
Thu Sep 3 21:20:25 EDT 2009

Michael Hutchinson wrote:
> On Thu, Sep 3, 2009 at 7:56 AM, Edward
> Diener<eldlistmailingz at tropicsoft.com> wrote:
>> Monodoc, from mono-tools, was never installed when I installed
>> monodevelop. Somebody left out that dependency when the monodevelop
>> package was created for OpenSUSE x86_64 11.1. Once I installed
>> mono-tools, and monodoc was therefore installed, everything worked properly.
> I've filed this: https://bugzilla.novell.com/show_bug.cgi?id=536695
> (My trunk packages already had this issue fixed, FWIW)

The same packaging problem for monodevelop 2.0 x86_64 showed up in 
Mandriva 2009.1 and Fedora 11. It does not seem as if the mono-tools 
package was installed as a dependency when monodevelop was packaged.

It is barely possible that the error is in my package manager, since I 
ue Smart rather than the different package managers of Suse ( Yast ), 
Mandriva ( Drake ), and Fedora ( PackageKit ). I do it because Smart 
gives me the same interface, which I like anyway. I have noticed some 
occasions where Smart 1.2 seems to get confused between i586 and x86_64 
packages with the same base name, but I have never seen a situation 
where Smart did not pick up package dependencies correctly.

Why do I run 3 Linux distros ? When I write modules or programs using 
monodevelop and C#, I want to be able to test them on different distros.

More information about the Monodevelop-list mailing list