[MonoDevelop] MonoDevelop 2.2b crashes on launch under Mac 10.6.1

Michael Hutchinson m.j.hutchinson at gmail.com
Sun Nov 15 17:50:40 EST 2009

On Tue, Nov 3, 2009 at 4:55 AM, Casemon <casemon at gmail.com> wrote:
> Using MonoFramework- which is supposed to have
> the needed dependencies... but no go. Or is there some dependency that is
> not installed?
> Been wrestling this for over a week... jumping through many hoops, but still
> no go.
> Have tried replacing the last line in MonoDevelop launch script with the OSX
> version line suggested here on the forums, but nothing.

What' is this change people have been suggesting?

> Have also tried deleting ~/.config/MonoDevelop, but still crashes
> immediately.
> Seems strange more people are not getting this error; have searched here,
> and far & wide, tried a few seemingly related solutions, but still nothing!
> Any ideas?

Nope, I need a full log from the second launch of an unmodified MD.
You log only showed a known bug that only happens the first time MD is
started after moving or updating the app bundle, and an issue with the
changes you made to the exec line in the launch script.

Can you try the MD from
and file a bug with the log from ~/.config/MonoDevelop/log (in later
builds it will be in ~/Library/Logs/MonoDevelop/MonoDevelop.log):


Michael Hutchinson

More information about the Monodevelop-list mailing list