[MonoDevelop] MonoDevelop on Mac OS X (building from SVN/2.0 and the binary package)

Tiago Taveira tiagotaveira at gmail.com
Mon Apr 27 15:04:19 EDT 2009

Hi again,

> The issues is that the launch script doesn't work with the version of
> bash in 10.5. Unfortunately I don't have a 10.4 machine to be able to
> make and test fixes.

Maybe I can try it out if you poing me in the right direction :)

> I wonder if that's 10.4-specific too. Are you using Mono 2.4 from  
> the installer?
> You might be able to fix it by putting libglib-2.0.dylib is in the
> LD_LIBRARY PATH, if that applies to Macs.

Yes, I tried Mono 2.2 and 2.4 from the installer.
I believe OS X uses DYLD_LIBRARY_PATH. I tried adding the path to  
libglib-2.0 (which is /opt/local/lib/) but I didn't quite work... it  
started complaining about other libraries upon starting (http:// 

I also tried adding the path of the libraries referenced in the  
errors to DYLD_LIBRARY_PATH but no go...

On Tue, Apr 21, 2009 at 5:36 PM, Tiago Taveira  
<tiagotaveira at gmail.com> wrote:
> Hi.
> I'm having some issues running MonoDevelop, having tried some
> possible solutions...
> First off, the binary package for my OS (Mac OS X 10.4.11 on PowerPC)
> available from the site just exits upon launch.
> Error on console.log says the following:
> /Applications/MonoDevelop.app/Contents/MacOS/monodevelop: line 35:
> syntax error near unexpected token `"$arg"'
> /Applications/MonoDevelop.app/Contents/MacOS/monodevelop: line 35: `
> MONO_OPTIONS+=("$arg")'
> I also tried building from source using both the current SVN, and the
> MonoDevelop 2.0 source. What I did was to use the configure options
> from ../profile/mac from the SVN version.
> Both are successful (although with some warnings...) and produce a
> binary runnable with 'make run'. What happens though is that
> MonoDevelop launches fine but when using some elements such as
> editing a file or producing project Makefiles it just throws an error
> related with libglib-2.0.dylib. A stack trace can be found here:
> http://pastebin.com/m606ce7f3 (note the "ERROR [2009-04-18
> 23:50:31Z]: System.DllNotFoundException: libglib-2.0.dylib").
> (...)

More information about the Monodevelop-list mailing list