[MonoDevelop] MonoDevelop on Mac OS X (building from SVN/2.0 and the binary package)

Tiago Taveira tiagotaveira at gmail.com
Tue Apr 21 17:36:32 EDT 2009


I'm having some issues running MonoDevelop, having tried some  
possible solutions...

First off, the binary package for my OS (Mac OS X 10.4.11 on PowerPC)  
available from the site just exits upon launch.
Error on console.log says the following:
/Applications/MonoDevelop.app/Contents/MacOS/monodevelop: line 35:  
syntax error near unexpected token `"$arg"'
/Applications/MonoDevelop.app/Contents/MacOS/monodevelop: line 35: `		 

I also tried building from source using both the current SVN, and the  
MonoDevelop 2.0 source. What I did was to use the configure options  
from ../profile/mac from the SVN version.
Both are successful (although with some warnings...) and produce a  
binary runnable with 'make run'. What happens though is that  
MonoDevelop launches fine but when using some elements such as  
editing a file or producing project Makefiles it just throws an error  
related with libglib-2.0.dylib. A stack trace can be found here:  
http://pastebin.com/m606ce7f3 (note the "ERROR [2009-04-18  
23:50:31Z]: System.DllNotFoundException: libglib-2.0.dylib").

Also, I found this post on the forums: http://go-mono.com/forums/ 
#nabble-td19063517 and I tried adding the entries said by Mike  
Cleaver to /Library/Frameworks/Mono.framework/Home/etc/mono, with no  

I tried both with the Mono Framework 2.2 and 2.4.

I understand that the OS X port still has some issues as stated on  
the project page, but I was wondering if there's a I could get it  
work, since it's the only machine at home I have access to to do .NET  
development. So, any help is greatly appreciated :)

PS: Sorry about the extensive post.

Best regards,

More information about the Monodevelop-list mailing list