[MonoDevelop] Problem editing Project with SVN

Charles Mason charlie.mas at gmail.com
Tue Oct 7 04:26:57 EDT 2008

Success !!! Since mono 2.0 was just released I decided to get the
source tar and build it rather than using a recent SVN build. Anyway
with mono 2.0 installed I reran the installed Mono Develop, it had the
same problem as before.

Anyway I decided to make install the SVN build that was installed. I
did a make clean then an SVN update (I think updated it 2 days before)
then reconfigured, built it. Initially I ran it via make run, that
worked fine. So I make installed it and now its running really well.

I now have an odd theme bug which makes the centre of the tabs and
scroll bars fade to white. Its hard to describe, buts that's a problem
for another day. I have had this before with this theme. It only
happens in mono develop not banshee or any other GTK Sharp app.

I am not sure if moving back to mono 2.0 solved it, the reinstall
process or perhaps something in the SVN update I did.

Anyway thanks again for the previous suggestions.

Charlie M

On Mon, Oct 6, 2008 at 10:20 AM, Charles Mason <charlie.mas at gmail.com> wrote:
> On Sat, Oct 4, 2008 at 9:35 PM, Michael Hutchinson
> <m.j.hutchinson at gmail.com> wrote:
>> On Sat, Oct 4, 2008 at 6:09 AM, Charles Mason <charlie.mas at gmail.com> wrote:
>>> On Fri, Oct 3, 2008 at 7:30 PM, Michael Hutchinson
>>> <m.j.hutchinson at gmail.com> wrote:
>>>> The addin database may be getting mixed up between these versions.
>>>> Also, if you have installed multiple versions of MonoDevelop into the
>>>> same location without removing older version, you may have conflicting
>>>> incompatible dlls installed.
>>>> I suggest clearing out the ${prefix}/lib/monodevelop for each of your
>>>> installations, then reinstalling. Also try removing the addin database
>>>> at ~/.config/MonoDevelop/addin*
>>>> Note that with multiple versions of MD using the same addin DB, there
>>>> may be some confusion. You could try overriding MONO_ADDINS_REGISTRY:
>>>> http://monodevelop.com/Environment_Variables when running one of your
>>>> MD version so that they don't share the same DB.
>>> Thank you for your suggestions. I have tried removing all references
>>> to Mono develop then reinstalling including removing the mono develop
>>> config folder in the home directory. I still can't get it working.
>>>> Also, using "make run" to run MonoDevelop without installing it is a
>>>> good plan when running development versions, as this should never
>>>> conflict with installed versions.
>>> That sounds like the best way to run development versions. I have
>>> tried running both the latest SVN and the 1.0 build this way and both
>>> still have the same problem. Would they not be effected if there was a
>>> problem with a library in the GAC or does mono develop not install its
>>> libraries to the GAC?
>> MD doesn't put anything in the GAC at all. However, Mono.Addins and
>> GTK# are in the GAC. What Mono and GTK# versions do you have, and how
>> did you install them?
> Sorry I missed this bit from my last reply. Everything is installed
> from a recent SVN check out. They are all built as per normal and
> installed with the prefix /usr.
> Mono its self is built from the SVN so I could get a recent version
> for the debugger. The original reason I was using  SVN versions and
> not the current release. Mono appears to be working fine with other
> lagre mono applications (like banshee), so I am fairly confident its
> install is good.
> Charlie M

More information about the Monodevelop-list mailing list