[MonoDevelop] Problem editing Project with SVN

Michael Hutchinson m.j.hutchinson at gmail.com
Sat Oct 4 16:35:05 EDT 2008

On Sat, Oct 4, 2008 at 6:09 AM, Charles Mason <charlie.mas at gmail.com> wrote:
> On Fri, Oct 3, 2008 at 7:30 PM, Michael Hutchinson
> <m.j.hutchinson at gmail.com> wrote:
>> The addin database may be getting mixed up between these versions.
>> Also, if you have installed multiple versions of MonoDevelop into the
>> same location without removing older version, you may have conflicting
>> incompatible dlls installed.
>> I suggest clearing out the ${prefix}/lib/monodevelop for each of your
>> installations, then reinstalling. Also try removing the addin database
>> at ~/.config/MonoDevelop/addin*
>> Note that with multiple versions of MD using the same addin DB, there
>> may be some confusion. You could try overriding MONO_ADDINS_REGISTRY:
>> http://monodevelop.com/Environment_Variables when running one of your
>> MD version so that they don't share the same DB.
> Thank you for your suggestions. I have tried removing all references
> to Mono develop then reinstalling including removing the mono develop
> config folder in the home directory. I still can't get it working.
>> Also, using "make run" to run MonoDevelop without installing it is a
>> good plan when running development versions, as this should never
>> conflict with installed versions.
> That sounds like the best way to run development versions. I have
> tried running both the latest SVN and the 1.0 build this way and both
> still have the same problem. Would they not be effected if there was a
> problem with a library in the GAC or does mono develop not install its
> libraries to the GAC?

MD doesn't put anything in the GAC at all. However, Mono.Addins and
GTK# are in the GAC. What Mono and GTK# versions do you have, and how
did you install them?

> To illustrate my problem I have uploaded a screen shot to image shack.
> http://img90.imageshack.us/my.php?image=monodevelopprobolemui0.jpg
> Is this likely a symptom of a damaged project addin, if so wouldn't I
> likely see an error message of some sort in mono develop. Can I use
> the addin managed to check if the correct addins are loaded and their
> versions?

I'd expect to see error messages, yes. Could you try a clean rebuild
of MD with "make clean", "svn st" to check no files have somehow been
locally modified, re-configure at the top level, and build again, then
"make run". That should 99% ensure nothing is "damaged".

Does this hppen with other projects?

Michael Hutchinson

More information about the Monodevelop-list mailing list