[MonoDevelop] Help installing monodevelop

James King james.king at 4act.com
Thu Nov 6 13:07:34 EST 2008

Thanks for all of your help.

I managed to get everything working from your help and reading the
http://monodevelop.com/Development:_Getting_Started and the link from there
about Setting up a parallel mono environment.

Somehow my paths are wrong for mono and I assume it is because of the
environment variables because creating and using the following script
allowed me to build and run monodevelop

export ACLOCAL_PATH=$MONO_PREFIX/share/aclocal
export PKG_CONFIG_PATH=$MONO_PREFIX/lib/pkgconfig:$GNOME_PREFIX/lib/pkgconfig
PS1="[mono] \w @ "

If anyone can help me understand why what I did allowed me to compile and
run monodevelop I would appreciate the extra knowledge. In my default
environment none of the above environment variables are set (when I check
with the env command). Why then, when I added them, did my applications know
to look in the /usr folder for mono instead of the /usr/local folder?

also, why when I compile gtk# with the /usr/local prefix did it not add the
required gconf-sharp-peditors.dll into the

lastly why when I try to compile monodoc from source do I get an error about
strong names for the assembly

If anyone has something to share (articles to read) that would help me
answer the above questions I would appreciate it.

I am a tinkerer and I am quite sure that my copy of linux is held together
with duct tape and chewing gum by now with all I have done, but that's the
way I learn best.

Thanks for everyone being willing to help a newb.


On Thu, Nov 6, 2008 at 10:47 AM, James King <james.king at 4act.com> wrote:

> Ok,
> I have learned quite a bit. I have installed all of the dependencies for
> monodevelop. However, I believe when I try to compile it is still looking in
> /usr/local for mono (I tried building that at some point also). Is there an
> easy way to change it back to /usr where all of my packages have been
> installed?
> Thanks,
> James
> On Wed, Nov 5, 2008 at 5:08 PM, Michael Hutchinson <
> m.j.hutchinson at gmail.com> wrote:
>> On Wed, Nov 5, 2008 at 5:53 PM, James King <james.king at 4act.com> wrote:
>> > I'm a .Net developer trying to move away from Windows and Visual Studio.
>> I
>> > am practically new to Linux and new to monodevelop. I currently use
>> Ubuntu
>> > Hardy amd64.
>> >
>> > I have tried the Ubuntu package for monodevelop and it works okay.
>> However,
>> > my current project is an asp.net web project and would like to try and
>> > utilize some of the new features of monodevelop 2 alpha.
>> >
>> > I have a few questions.
>> >
>> > 1. Can I compile and install monodevelop without ruining my current
>> > monodevelop 1 installation?
>> Not easily. However, if you build from source  you can use it without
>> installing it if you build from source. Use "make run".
>> > I have tinkered a little on my own and download the releases
>> >
>> > 1. mono-addins-0.3.1
>> > 2. monodevelop-1.9
>> > 3. monodoc-1.2.6
>> > 4. gtk-sharp-
>> >
>> > I can compile mono addins without any errors. I can compile gtk-sharp
>> > without any errors. I get some error about a strong assembly name when
>> > compiling monodoc, but I am not super concerned with that at the moment.
>> > When I try to compile monodevelop I have some trouble
>> >
>> > 1. the readme says to run ./configure --prefix=`pkg-config
>> --variable=prefix
>> > mono`
>> >    what is the --prefix=`pkg-config --variable=prefix mono`? If I type
>> that
>> > in exactly I get an error saying "configure: error: expected an absolute
>> > directory name for --prefix: pkg-config --variable=prefix mono"
>> >
>> > If I do not add the --prefix option then configure seems to work fine,
>> but
>> > the make command produces an error "error CS0006: cannot find metadata
>> file
>> >
>> `/usr/local/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gconf-sharp-peditors.dll'"
>> >
>> > I assumed that gtk-sharp was supposed to add that
>> (gconf-sharp-peditors.dll)
>> > file. However it does not.
>> Your paths and install locations are messed up. When installing from
>> source, I strongly recommend a parallel install.
>> I suggest you find Mono 2.0 and GTK# 2.12.5 packages for Ubuntu and
>> install them. If you can't find packages, build and install them in a
>> parallel install. Then build MD from source -- preferably the upcoming
>> 20 alpha 2, or SVN; 2.0 alpha 1 is getting old. Don't install it; use
>> "make run".
>> The page http://monodevelop.com/Development:_Getting_Started has some
>> instructions on building/running MD from SVN.
>> The *really* easy option is to use the Mono 2.0 openSUSE VMWare image,
>> and use my MonoDevelop trunk packages:
>> http://software.opensuse.org/search?baseproject=openSUSE%3A11.0&p=1&q=monodevelop-debugger-mdb
>> --
>> Michael Hutchinson
>> http://mjhutchinson.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20081106/730a1581/attachment.html 

More information about the Monodevelop-list mailing list