[MonoDevelop] Crash when I open project...

Paul paul at all-the-johnsons.co.uk
Thu Jul 17 10:29:14 EDT 2008


> I am using Fedora 8, kernel 2.6.23. I also tried removing and reinstalling
> with kernel 2.6.25 and faced the exact same issue.
> Also when I try a yum update i get the following error >> "mono-core
> conflicts with mono-addins <= 0.3"

You shouldn't be getting those errors as mono-addins only checks to see
(when it builds) that it's building against mono-devel >= 1.2.3 and it
was certainly built on koji fine.

> I am not sure if the problems are related.

Did you build mono or mono-addins yourself or did you use the Fedora
rpms for both?

> This first error appears when I run monodevelop but it still opens ok
> Error: did not find one of the files in
> sources//usr/lib/monodoc/sources/monoapi 

There isn't a file called that - there is monoapi.source, monoapi.tree
and monoapi.zip

> Below are all the messages that appear when I try to open my project
> Exception in Gtk# callback delegate
>   Note: Applications can use GLib.ExceptionManager.UnhandledException to
> handle the exception.
> GLib.MissingIntPtrCtorException: GLib.Object subclass
> MonoDevelop.Ide.Gui.Dialogs.FileSelectorDialog must provide a protected or
> public IntPtr ctor to support wrapping of native object handles.

This looks like there is a problem generating a file dialog box which
would be down to gtk-sharp2. Do you have gnome-sharp, gtk-sharp2 and
gtk-sharp2-gapi installed?


Monodevelop packager, Fedora
Sie können mich aufreizen und wirklich heiß machen!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://lists.ximian.com/pipermail/monodevelop-list/attachments/20080717/996b6158/attachment.bin 

More information about the Monodevelop-list mailing list