[MonoDevelop] running outside MD enviironment

Dan Smithers dsmithers at talktalk.net
Wed Feb 6 04:17:23 EST 2008

Michael Hutchinson wrote:
> On Feb 4, 2008 5:34 AM, Dan Smithers <dsmithers at talktalk.net> wrote:
>> I would like to run my application directly from the command line. I get
>> an assembly error :- can't find Mono.Posix version
>> It runs fine from inside MD so the assembly must be present.
> MD makes local copies of assemblies that aren't in the GAC.
>> I have tried adding /usr/local/lib/mono/2.0 to LD_LIBRARY_PATH but I
>> still get the same error.
> Mono doesn't use LD_LIBRARY_PATH for managed libraries -- use
> MONO_GAC_PREFIX or MONO_PATH, as documented here:
> http://www.mono-project.com/Parallel_Mono_Environments
> FWIW, if you have multiple Monos you should really be careful to keep
> them separated. In particular:
> http://mjhutchinson.com/journal/2007/11/08/how_not_break_mono
>> There appears to be an entry in the GAC.
> As evidenced by "gacutil -l"?

yes - and the public keys match.

I'll look into your other suggestions.



More information about the Monodevelop-list mailing list