[MonoDevelop] Running configure under Cygwin in Windows - "Can't find 'mono' in PATH"

Huk Huk256 at gmail.com
Tue Dec 23 15:38:46 EST 2008

Christian Hoff wrote:
> Huk wrote:
>> Well earlier it didn't work... but now it DID :)
> cool :-)
>> I managed to compile mono from svn - now... any ideas how to run this
>> thing?
>> I guess that I should not run this from Cygwin, right?
>> Anyway I tried that - make install and then monodvelop I get:
>> $ monodevelop
>> WARNING: Cannot find Mozilla directory containing libgtkembedmoz.so. Some
>> Addins
>>  may not be able to function. Please set MOZILLA_FIVE_HOME to your
>> Mozilla
>> direc
>> tory.
>> WARNING [2008-12-22 20:27:50Z]: Gtk-Warning: cannot open display:
>> Stack trace:
>>    at Gtk.Application.Init()
>>    at MonoDevelop.Ide.Gui.IdeStartup.Run(System.String[] args)
>>    at MonoDevelop.Startup.SharpDevelopMain.Main(System.String[] args)
> No idea why Gtk cannot open the display(running my own Gtk# apps from a 
> Cygwin console worked), but yeah, you'd better try to run md from a 
> Windows shell then.
>> From Cygwin-X I get:
>> shm_semaphores_init: semget error: No space left on device...
>> If I try it under pure Windos - I get:
>> I:\cyg_mono\monodevelop\main\build\bin>c:\Mono-2.0.1\bin\mono.exe --debug
>> MonoDe
>> velop.exe -ipc-tcp
>> ** (MonoDevelop.exe:3912): WARNING **: The following assembly referenced
>> from I:
>> \cyg_mono\monodevelop\main\build\bin\MonoDevelop.Core.dll could not be
>> loaded:
>>      Assembly:   Mono.Addins.Setup    (assemblyref_index=7)
>>      Version:
>>      Public Key: 0738eb9f132ed756
>> The assembly was not found in the Global Assembly Cache, a path listed in
>> the MO
>> NO_PATH environment variable, or in the location of the executing
>> assembly
>> (I:\c
>> yg_mono\monodevelop\main\build\bin).
>> ** (MonoDevelop.exe:3912): WARNING **: Could not load file or assembly
>> 'Mono.Add
>> ins.Setup, Version=, Culture=neutral,
>> PublicKeyToken=0738eb9f132ed756' or
>>  one of its dependencies.
>> ** (MonoDevelop.exe:3912): WARNING **: Could not load file or assembly
>> 'Mono.Add
>> ins.Setup, Version=, Culture=neutral,
>> PublicKeyToken=0738eb9f132ed756' or
>>  one of its dependencies.
>> Unhandled Exception: System.TypeLoadException: A type load exception has
>> occurre
>> d.
>> Any ideas how do I run this?
> MonoDevelop cannot find all these assemblies in the global assembly 
> cache(GAC) where they should have been installed by running "make
> install".
> Try to find these assemblies(they will probably be in the directory from 
> which you compiled the sources, simply search for *.dll), start the Mono 
> shell(which will include the mono bin directory in the PATH of the 
> console session) and run gacutil /i "PATH_TO_MonoDevelop.Core.dll". Do 
> the same with all the other assemblies. "gacutil /l" will give you a 
> list of all assemblies that have been installed into the GAC.
> Christian
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list

Well adding dlls with gacutil didn't work - or rather it worked but MD still
didn't saw it - so I simply copied all dlls to MD.exe dir - now it saw dll's
but there were errors:

Unhandled Exception: System.NullReferenceException: Object reference not set
an instance of an object
  at MonoDevelop.Core.Runtime.Initialize (Boolean updateAddinRegistry)
  at MonoDevelop.Startup.SharpDevelopMain.Main (System.String[] args)

There were also errors like "Library X is not a compatible library" -
however they shown only once - after copying dlls...

Oh I almost forgot - I had to compile gtk-sharp.dll 2.12 myself - I have no
idea if I managed to do it correctly, because while I was compiling this
lib, compiler was complaining that it couldn't find files like:

gtk-sharp.raw, glib-sharp.raw and so on for other components - and google
gave no answers about this error so I simply created dummies of those files
and... it worked...

Then I copied gtk-sharp.dll to MD.exe dir – of course that didn't change
anything (beside it stopped complaining about missing assembly)

Any other ideas what else could I try?

Thanks in advance.
View this message in context: http://www.nabble.com/Running-configure-under-Cygwin-in-Windows---%22Can%27t-find-%27mono%27-in-PATH%22-tp21043693p21150937.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list