[MonoDevelop] 2.0a2 monodevelop-debugger-* package installation failure

Atsushi Eno atsushi at ximian.com
Wed Dec 17 20:12:47 EST 2008

Ugh, actually the fact seems somewhat different. The rpm packages are in
fact fine, but the ymp linked from
tries to install monodevelop from 1.0 (stable), and then it causes
conflict with those debugger packages. Probably that ymp was for stable
MD and there should be another ymp for unstable packages.

Atsushi Eno

> Hello,
> I was trying to install monodevelop 2.0 packages (aside from my
> build from trunk), through ymp first, and then rpms directly.
> Neither worked fine. When I tried rpm installation, I got:
> atsushi at linux-avjl:~> LANG=C sudo rpm -i ~/Desktop/monodevelop-debugger-*
> error: Failed dependencies:
> 	mono(Mono.Debugging) = is needed by
> monodevelop-debugger-gdb-1.9.1-1.1.noarch
> 	mono(MonoDevelop.Core) = is needed by
> monodevelop-debugger-gdb-1.9.1-1.1.noarch
> 	mono-debugger >= 2.0 is needed by monodevelop-debugger-mdb-1.9.1-2.1.noarch
> 	mono(Mono.Debugger) = is needed by
> monodevelop-debugger-mdb-1.9.1-2.1.noarch
> 	mono(Mono.Debugging) = is needed by
> monodevelop-debugger-mdb-1.9.1-2.1.noarch
> Probably rpm specs are broken?
> Atsushi Eno
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list

More information about the Monodevelop-list mailing list