[MonoDevelop] Adding libraries

Dan Smithers dsmithers at talktalk.net
Thu Nov 15 06:34:11 EST 2007

Thanks Lluis,
When I wrote resources, I really meant references. The GUI that I have
been developing seems to have problems importing libraries as .NET
assemblies and displays an error when I try to do it.

I have now tried on an even smaller test and it compiles - but doesn't
run as it can't find methods in System.Net.Sockets which don't seem to
be included by default nor available in the Edit References pane.



Lluis Sanchez wrote:
> El dj 15 de 11 del 2007 a les 03:24 -0500, en/na dsmithers at talktalk.net
> va escriure:
>> Hi,
>> I am really struggling trying to add extra libraries to a monodevelop
>> GUI app that I have developed.
>> I have written a socket wrapper class and compiled this using make and
>> gmcs  on the command line.
>> I want to use this in a GTK# GUI that I have constructed using
>> monodevelop but can't get it to be seen by the compiler.
>> I have tried adding it as a resource, and adding it as a member of the
>> solution (copying the library).
>> I tried using DllImport with a wrapper for the wrapper.
>> I have also changed it so that it is a C# assembly and even tried
>> adding it to the GAC.
>> I get the Type or namespace name can't be found error.
> You have to add a reference to the assembly. In the project tree right
> click on the References node and select Edit References.
> Lluis.

More information about the Monodevelop-list mailing list