[MonoDevelop] Adding libraries

Martin Zaworski MartinZaworski at web.de
Thu Nov 15 05:39:46 EST 2007

I donŽt know if this would help, but i think you have to change the compiler inside of the monodevelop from 1.0 to 2.0.

just an idea, maybe it helps.


-----Ursprüngliche Nachricht-----
Von: dsmithers at talktalk.net
Gesendet: 15.11.07 10:29:57
An: monodevelop-list at lists.ximian.com
Betreff: [MonoDevelop] Adding libraries

I am really struggling trying to add extra libraries to a monodevelop GUI app that I have developed.
I have written a socket wrapper class and compiled this using make and gmcs  on the command line.
I want to use this in a GTK# GUI that I have constructed using monodevelop but can't get it to be seen by the compiler.

I have tried adding it as a resource, and adding it as a member of the solution (copying the library).

I tried using DllImport with a wrapper for the wrapper.

I have also changed it so that it is a C# assembly and even tried adding it to the GAC.

I get the Type or namespace name can't be found error.



Monodevelop-list mailing list
Monodevelop-list at lists.ximian.com

Jetzt neu! Schützen Sie Ihren PC mit McAfee und WEB.DE. 3 Monate
kostenlos testen. http://www.pc-sicherheit.web.de/startseite/?mc=022220

More information about the Monodevelop-list mailing list