[MonoDevelop] Monodevelop on Mac OSX using guide

Glenn R. Martin lifewarped at yahoo.com
Mon Mar 20 07:50:01 EST 2006

As a not here im having problems with  Gnome 2.14... and i cant  
reproduce the working install of OpenJade so im gonna have to patch  
GTK-Doc... once everything is done ill upload it to the server...

i havent tried th patch yet... it can be found here... http:// 
developer.imendio.com/wiki/Gtk_Mac_OS_X/Build_Instructions the build  
i have has everything from nothing all the way to OpenSP would you  
like the full thing or only gnome-vfs 2.12.2?

Eithercase its a test version and use at your own risk but with all  
"Open" software that goes without saying... feel free to try   
OpenJade... let me know if you run in to the same problem...

 From here on as i dont see how it would be helpfull to the list...  
grab me at my other address and off list...
ill be sure to post a note on the guide soon enough...
glenn at martinfamilyemail.net

On Mar 20, 2006, at 4:43 AM, Danny wrote:

> That would be great.
> Would you be able to put it on the server with the compilekit so  
> anyone who has the same problem could get access to it? Otherwise  
> you can mail it to me.
> And btw: Thanks for the great work on the guide. Otherwise it would  
> have been near impossible for me to get near this thing.
> Regards
> Danny
> On 20/03/2006, at 5.18, Glenn R. Martin wrote:
>> Ive been working with 2.14 as of late... i never came across that  
>> error... Im working on installer packages for OS X... i have a  
>> gnome-vfs one if youd like it.
>> Glenn Martin...
>> ill try the compile again see if i can reproduce the error...
>> On Mar 19, 2006, at 6:24 PM, Danny wrote:
>>> I'm trying to install Monodevelop on my OS X 10.4.5 mac using the  
>>> "Running on OSX" guide (www.monodevelop.org/Running_On_OSX)
>>> I have succesfully compiled many of the packages but one is  
>>> really causing me headache.
>>> First when I tried to install gnome-vfs 2.12.2 i got the error:
>>> ld: Undefined symbols:
>>> _res_9_dn_expand
>>> _res_9_init
>>> _res_9_search
>>> /usr/bin/libtool: internal link edit command failed
>>> make[3]: *** [libgnomevfs-2.la] Error 1
>>> make[2]: *** [all] Error 2
>>> make[1]: *** [all-recursive] Error 1
>>> make: *** [all] Error 2
>>> I got around this by doing:
>>> export CFLAGS="-DBIND_8_COMPAT=1"
>>> But know when i compile it I get the following error:
>>> gnome-vfs-dns-sd.c: In function 'unicast_resolve_sync':
>>> gnome-vfs-dns-sd.c:663: error: 'T_SRV' undeclared (first use in  
>>> this function)
>>> gnome-vfs-dns-sd.c:663: error: (Each undeclared identifier is  
>>> reported only once
>>> gnome-vfs-dns-sd.c:663: error: for each function it appears in.)
>>> make[3]: *** [gnome-vfs-dns-sd.lo] Error 1
>>> make[2]: *** [all] Error 2
>>> make[1]: *** [all-recursive] Error 1
>>> make: *** [all] Error 2
>>> I haven't been able to get around this in any ways. The ./ 
>>> configure script only warns about the missing FAM support which  
>>> should be normal according to the guide.
>>> Hope someone can help me resolve this.
>>> _______________________________________________
>>> Monodevelop-list mailing list
>>> Monodevelop-list at lists.ximian.com
>>> http://lists.ximian.com/mailman/listinfo/monodevelop-list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20060320/dd0e8b51/attachment-0001.html

More information about the Monodevelop-list mailing list