[MonoDevelop] Monodevelop won't start, seems not to be able to find a library

Karl Martindale karl at posmaster.com.au
Sun Feb 26 20:26:52 EST 2006

This is the part that confuses me:
karl at ssh:~$ echo $LD_LIBRARY_PATH

Which is the path where all these libraries are stored.

Damn! Found it.
Changing the line in .bash_profile from:
export LD_LIBRARY_PATH="/opt/mono-1.1.12/lib:$LD_LIBRARY_PATH"
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/mono-1.1.12/lib"
rectifies the problem.

So, having a delimiter on the end rather than at the start causes the path to be 
mis-interpreted. The world is once again a happy place.

Thanks for reading.


Lluis Sanchez wrote:
> Mono should be loading libraries from directories in LD_LIBRARY_PATH,
> and /opt/mono-1.1.12/lib is being added in .bash_profile. What do you
> get if you run this from a terminal?: echo $LD_LIBRARY_PATH
> El vie, 24-02-2006 a las 17:31 +1100, Karl Martindale escribió:
>>It's alive!
>>Thanks for that Lluis, the log told me that while being loaded as you suggested 
>>monodevelop was checking the current directory for it's libraries:
>>Mono-INFO: DllImport attempting to load: 'gnomesharpglue-2'.
>>Mono-INFO: DllImport loading location: 'libgnomesharpglue-2.so'.
>>Mono-INFO: DllImport error loading library: 'libpanel-applet-2.so.0: cannot open 
>>shared object file: No such file or directory'.
>>Mono-INFO: DllImport loading library: './libgnomesharpglue-2.so'.
>>So when I ran:
>>MONO_LOG_LEVEL=debug mono /usr/local/lib/monodevelop/bin/MonoDevelop.exe > 
>>from the directory:
>>Monodevelop runs starts up ok (it can't find a mozilla library, but still starts)
>>(MonoDevelop:22324): Mono-WARNING **: DllImport unable to load library 
>>'libgtkembedmoz.so: cannot open shared object file: No such file or directory'.
>>My query now is, where do I tell mono / monodevelop where to find these 
>>libraries so I don't need to start from the /mono/lib directory? I've got the 
>>environment variables that I know about setup, are there more?
>>Thanks again for helping me get this far!
>>Lluis Sanchez wrote:
>>>Try the following: cd to the directory where you have MonoDevelop
>>>installed (something like /usr/lib/monodevelop/bin) and run:
>>>MONO_LOG_LEVEL=debug mono MonoDevelop.exe > debug.log
>>>Maybe the log has some clues about the problem. Look for gnomesharpglue.
>>>El mié, 22-02-2006 a las 16:25 +1100, Karl Martindale escribió:
>>>>Hi all,
>>>>I'm trying to set up monodevelop on a box at work so we can 'get mono' here :)
>>>>The machine is running Slackware Linux 10.2
>>>>I tried a number of the pre-compiled mono distributions before I found one that 
>>>>monodevelop-0.9 would compile against, but found that 
>>>>mono-1.1.12_0-installer.bin seemed to compile and install successfully.
>>>>I've found a number of folk that have had similar sounding problems to me on 
>>>>various forums and mailing lists.  I've tried to include information that covers 
>>>>each of the solutions addressed elsewhere.  Unfortunately monodevelop still 
>>>>doesn't start and this is my first taste of anything mono, so I'm kinda at loss 
>>>>of what else to try.
>>>>Another thing to note would be that although Gnome is no longer included as part 
>>>>of the Slackware distribution I installed it using the freerock gnome projects 
>>>>lynx --source http://gsb.freerock.org/net-install | sh
>>>>When I try and start monodevelop the error I get is:
>>>>-------  CUT  -------
>>>>System.TypeInitializationException: An exception was thrown by the type 
>>>>initializer for Gnome.ModuleInfo ---> System.DllNotFoundException: gnomesharpglue-2
>>>>in (wrapper managed-to-native) 
>>>>Gnome.ModuleInfo:gnomesharp_gnome_moduleinfo_get_name_offset ()
>>>>in <0x00008> Gnome.ModuleInfo:.cctor ()--- End of inner exception stack trace ---
>>>>in <0x00000> <unknown method>
>>>>in <0x00025> Gnome.Modules:get_UI ()
>>>>in <0x00440> MonoDevelop.Ide.Gui.IdeStartup:Run (System.String[] args)
>>>>in <0x00169> MonoDevelop.Core.AddIns.AddInService:StartApplication 
>>>>(System.String addinId, System.String[] parameters)
>>>>-------  CUT  -------
>>>>Mono related environment variable found in ~/.bash_profile are:
>>>>export PATH="/opt/mono-1.1.12/bin:$PATH"
>>>>export PKG_CONFIG_PATH="/opt/mono-1.1.12/lib/pkgconfig:$PKG_CONFIG_PATH"
>>>>export MANPATH="/opt/mono-1.1.12/share/man:$MANPATH"
>>>>export LD_LIBRARY_PATH="/opt/mono-1.1.12/lib:$LD_LIBRARY_PATH"
>>>>export MOZILLA_FIVE_HOME="/usr/bin"
>>>>result of "ls -l /opt/mono-1.1.12/lib/*gnomesharpglue*"
>>>>-rwxr-xr-x  1 root root 11988 2005-12-20 10:54 
>>>>-rwxr-xr-x  1 root root 12528 2005-12-20 10:54 
>>>>contents of /etc/ld.so.conf
>>>>output of "ldconfig -p | grep libgnomesharpglue"
>>>>        libgnomesharpglue.so (libc6) => /opt/mono-1.1.12/lib/libgnomesharpglue.so
>>>>        libgnomesharpglue-2.so (libc6) => 
>>>>Any suggestions as to what I'm missing will be gratefully received.
>>>>Thanks in advance,
>>>>Monodevelop-list mailing list
>>>>Monodevelop-list at lists.ximian.com

More information about the Monodevelop-list mailing list