[MonoDevelop] Monodevelop won't start

peter apvx95 at dsl.pipex.com
Thu Feb 23 13:22:15 EST 2006

Hmm.  I had a go at that (because I've been having a similar problem).  
The attached file gives what I got.  I don't know if it's the same as 
Karl will get.


Lluis Sanchez wrote:

>Try the following: cd to the directory where you have MonoDevelop
>installed (something like /usr/lib/monodevelop/bin) and run:
>MONO_LOG_LEVEL=debug mono MonoDevelop.exe > debug.log
>Maybe the log has some clues about the problem. Look for gnomesharpglue.
>El mié, 22-02-2006 a las 16:25 +1100, Karl Martindale escribió:
>>Hi all,
>>I'm trying to set up monodevelop on a box at work so we can 'get mono' here :)
>>The machine is running Slackware Linux 10.2
>>I tried a number of the pre-compiled mono distributions before I found one that 
>>monodevelop-0.9 would compile against, but found that 
>>mono-1.1.12_0-installer.bin seemed to compile and install successfully.
>>I've found a number of folk that have had similar sounding problems to me on 
>>various forums and mailing lists.  I've tried to include information that covers 
>>each of the solutions addressed elsewhere.  Unfortunately monodevelop still 
>>doesn't start and this is my first taste of anything mono, so I'm kinda at loss 
>>of what else to try.
>>Another thing to note would be that although Gnome is no longer included as part 
>>of the Slackware distribution I installed it using the freerock gnome projects 
>>lynx --source http://gsb.freerock.org/net-install | sh
>>When I try and start monodevelop the error I get is:
>>-------  CUT  -------
>>System.TypeInitializationException: An exception was thrown by the type 
>>initializer for Gnome.ModuleInfo ---> System.DllNotFoundException: gnomesharpglue-2
>>in (wrapper managed-to-native) 
>>Gnome.ModuleInfo:gnomesharp_gnome_moduleinfo_get_name_offset ()
>>in <0x00008> Gnome.ModuleInfo:.cctor ()--- End of inner exception stack trace ---
>>in <0x00000> <unknown method>
>>in <0x00025> Gnome.Modules:get_UI ()
>>in <0x00440> MonoDevelop.Ide.Gui.IdeStartup:Run (System.String[] args)
>>in <0x00169> MonoDevelop.Core.AddIns.AddInService:StartApplication 
>>(System.String addinId, System.String[] parameters)
>>-------  CUT  -------
>>Mono related environment variable found in ~/.bash_profile are:
>>export PATH="/opt/mono-1.1.12/bin:$PATH"
>>export PKG_CONFIG_PATH="/opt/mono-1.1.12/lib/pkgconfig:$PKG_CONFIG_PATH"
>>export MANPATH="/opt/mono-1.1.12/share/man:$MANPATH"
>>export LD_LIBRARY_PATH="/opt/mono-1.1.12/lib:$LD_LIBRARY_PATH"
>>export MOZILLA_FIVE_HOME="/usr/bin"
>>result of "ls -l /opt/mono-1.1.12/lib/*gnomesharpglue*"
>>-rwxr-xr-x  1 root root 11988 2005-12-20 10:54 
>>-rwxr-xr-x  1 root root 12528 2005-12-20 10:54 
>>contents of /etc/ld.so.conf
>>output of "ldconfig -p | grep libgnomesharpglue"
>>         libgnomesharpglue.so (libc6) => /opt/mono-1.1.12/lib/libgnomesharpglue.so
>>         libgnomesharpglue-2.so (libc6) => 
>>Any suggestions as to what I'm missing will be gratefully received.
>>Thanks in advance,
>>Monodevelop-list mailing list
>>Monodevelop-list at lists.ximian.com
>Monodevelop-list mailing list
>Monodevelop-list at lists.ximian.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug.log
Type: text/x-log
Size: 25609 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/monodevelop-list/attachments/20060223/c04582cd/debug-0001.bin

More information about the Monodevelop-list mailing list