[MonoDevelop] can't start MonoDevelop (dll not found: gnomesharpglue-2)

Zbynek Vrastil zvrastil at seznam.cz
Wed Sep 28 02:43:53 EDT 2005


I have tried to compile whole mono & monodevelop from sources and now it 
works. To compile all necessary assemblies from gtk-sharp package, I was 
forced to install some extra gnome libraries I did not have (I'm using 
KDE), like libgnomeprintui, gnome-icon-theme and libpanel-applet, so I 
suppose that those missing libraries was, what caused my problems with 
starting monodevelop from binary package.

regards, Zbynek

Zbynek Vrastil wrote:
> Thanks for the info, but unfortunately, something other has to be wrong 
> on my computer. I have added the library into ld.so.conf and executed 
> ldconfig. The output of the command
> $ldconfig -p | grep gnomesharpglue-2
> gives
> libgnomesharpglue-2.so (libc6) => 
> /usr/local/mono-
> but the error after running monodevelop is still the same. Any other ideas?
> regards, Zbynek
> Seb James wrote:
>> On Sun, 2005-09-25 at 20:22 +0200, Zbynek Vrastil wrote:
>>> Hi all,
>>> I've just installed Mono version from binary installer 
>>> package on Debian Testing, x86, into directory 
>>> /usr/local/mono- When I try to run MonoDevelop, I get 
>>> following error:
>>> Unhandled Exception: System.TypeInitializationException: An exception 
>>> was thrown by the type initializer for Gnome.ModuleInfo ---> 
>>> System.DllNotFoundException:gnomesharpglue-2
>>> in (wrapper managed-to-native) 
>>> Gnome.ModuleInfo:gnomesharp_gnome_moduleinfo_get_name_offset ()
>>> in <0x00008> Gnome.ModuleInfo:.cctor ()--- End of inner exception 
>>> stack trace ---
>>> in <0x00000> <unknown method>
>>> in <0x00025> Gnome.Modules:get_UI ()
>>> in <0x0042a> MonoDevelop.SharpDevelopMain:Main (System.String[] args)
>>> The library libgnomesharpglue-2.so is correctly installed in 
>>> /usr/local/mono- LD_LIBRARY_PATH includes the mono 
>>> library directory. I have tried to add line
>>> <dllmap dll="gnomesharpglue-2" target="libgnomesharpglue-2.so"/>
>>> into /usr/local/lib/monodevelop/bin/MonoDevelop.Base.dll.config as 
>>> well as into /etc/mono/config, but the error did not change.
>>> MonoDoc can be started without trouble.
>>> There are no debian mono packages installed in the system.
>>> Does anyone know what's wrong?
>>> thanks in advance, Zbynek
>> I had exactly this error, and then realised that I'd left my mono lib
>> directory out of ld.so.conf. I added the directory (in my
>> case /opt/mono/lib) to ld.so.conf and re-ran ldconfig and the program
>> runs. I see you have added your mono library path using LD_LIBRARY_PATH,
>> but all the same, I think the library is being missed by your system.
>> Hope that's of some help.
>> Seb
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list

More information about the Monodevelop-list mailing list