[MonoDevelop] Can't start monodevelop

Zbynek Vrastil zvrastil at seznam.cz
Fri Oct 14 16:05:58 EDT 2005

I had similar problem when I tried to use Mono and Monodevelop from 
binary installation. It was on Debian and I was getting little bit 
different error, but I think the problem could be the same.
Finally, I have tried to compile everything from source code and during 
the process, I have realized I'm missing some necessary gnome libraries 
(I use KDE by default). It seems that binary installer does not have 
complete dependency checking. I suggest to try to compile the source code.
Anyway, the missing libraries (packages) on my computer was 
libgnomeprintui, gnome-icon-theme and libpanel-applet.

regards, Zbynek

peter wrote:
> Hi,
> I obtained monodevelop 0.8.0 from rug and tried to run it.  This is the 
> result:
> peter at linux:~> monodevelop
> Unhandled Exception: System.TypeInitializationException: An exception 
> was thrown by the type initializer for Gnome.ModuleInfo ---> 
> System.EntryPointNotFoundException: 
> gnomesharp_gnome_moduleinfo_get_name_offset
> in (wrapper managed-to-native) 
> Gnome.ModuleInfo:gnomesharp_gnome_moduleinfo_get_name_offset ()
> in <0x00008> Gnome.ModuleInfo:.cctor ()--- End of inner exception stack 
> trace ---
> in <0x00000> <unknown method>
> in <0x00025> Gnome.Modules:get_UI ()
> in <0x0044c> MonoDevelop.SharpDevelopMain:Main (System.String[] args)
> peter at linux:~>
> I've been getting this error from monodevelop ever since I moved from 
> mono 1.0.x to mono 1.1.x.  I currently have mono on SuSE 9.3 Pro.
> I'd appreciate any help.
> Thanks
> Peter
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list

More information about the Monodevelop-list mailing list