[MonoDevelop] Compiling gtksourceview-sharp 0.7 for MonoDevelop 0.6 on OSX

Alessandro Lendaro alendaro1@virgilio.it
Thu, 24 Mar 2005 19:54:16 +0100


hi everybody.

I'm trying to compile monodevelop 0.6 on OSX.

I aleady compiled and successfully installed gtk-sharp 2.0, 1.0 and 
monodoc 1.0.6

now, gtksourceview-sharp 0.7

when I run configure, the last lines are:

checking for monodoc >= 1.0... yes
checking MONODOC_DEPENDENCY_CFLAGS... 
checking MONODOC_DEPENDENCY_LIBS... 
/r:/Library/Frameworks/Mono.framework/Versions/Current/lib/mono/gtk-sharp/monodoc.dll  

checking for monodoc... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating gtksourceview/AssemblyInfo.cs
config.status: creating gtksourceview/gtksourceview-sharp.dll.config
config.status: creating gtksourceview/Makefile
config.status: creating gtksourceview-sharp-2.0.pc
config.status: creating doc/Makefile
config.status: creating sample/Makefile
config.status: executing depfiles commands

and when I launch make:


Making all in gtksourceview
I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/gnome-api.xml 
-I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/pango-api.xml 
-I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/atk-api.xml 
-I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/gdk-api.xml 
-I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/gtk-api.xml 
-I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/art-api.xml   
--generate gtksourceview-api.xml \
--outdir=generated --customdir=. --assembly-name=gtksourceview-sharp && 
touch generated-stamp
/bin/sh: line 1: 
I:/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/gnome-api.xml: 
No such file or directory
make[1]: [generated-stamp] Error 127 (ignored)
/usr/bin/mcs --unsafe --target library /pkg:gnome-sharp-2.0 \
generated/*.cs ./GtkSourceView.cs AssemblyInfo.cs -o gtksourceview-sharp.dll
error CS2001: Source file `generated/*.cs' could not be found
Compilation failed: 1 error(s), 0 warnings
make[1]: *** [gtksourceview-sharp.dll] Error 1
make: *** [all-recursive] Error 1


Thanks to any who will help.


P.S.: I DO HAVE 
/Library/Frameworks/Mono.framework/Versions/Current/share/gapi-2.0/gnome-api.xml
and HAVE SET PKG_CONFIG_PATH = 
/sw/lib/pkgconfig:/usr/X11R6/lib/pkgconfig:/Library/Frameworks/Mono.framework/Versions/Current/lib/pkgconfig

--