[MonoDevelop] Problem running MonoDevelop

Elliott Draper el at eldiablo.co.uk
Tue Jul 19 12:21:14 EDT 2005

Hi guys,

I'm trying to get MonoDevelop up and running, and am compiling 
everything from source, and have got MonoDevelop and its dependencies 
built and installed as far as I can see. However, when running 
MonoDevelop, I get the following error:

Unhandled Exception: System.NullReferenceException: Object reference not 
set to an instance of an object
in <0x00000> <unknown method>
in (wrapper managed-to-native) System.Object:wrapper_native_0x4e8550b0 ()
in (wrapper native-to-managed) System.Object:wrapper_native_0x4e8550b0 ()
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gnome.Program:gtksharp_gnome_program_init 
in <0x00284> Gnome.Program:.ctor (System.String app_id, System.String 
app_version, ModuleInfo module, System.String[] argv, System.Object[] props)
in <0x00481> MonoDevelop.SharpDevelopMain:Main (System.String[] args)

Attached is the rather lengthy debug output, which may also prove useful.

I'm compiling and running on a P3 800Mhz, running Fedora Core 3. I've 
tried both compiling from SVN, and from a source tarball, both compile 
and install successfully, both with the same problem running. I've also 
tried "make run" direct from the compiled source directory, still no 
dice. This error isn't hugely descriptive I know, but maybe someone 
might have seen this error before and could shed some light on it? I'm 
also not sure what other information would prove useful to anyone 
wanting to help me out with this issue, so please just let me know if 
there's some other details that might prove handy in diagnosing the 
problem that I've omitted here.

My only inkling is an issue perhaps in it finding one of the lib*glue.so 
libs, however I've been playing with it for a few days now and have got 
nowhere, so thought I'd turn it over and see if anyone else can help :-)

-= El =-

More information about the Monodevelop-list mailing list