[MonoDevelop] Re: Cannot find assembly 'gecko-sharp.dll' errorwhen making MonoDevelop 0.3

chris me@blixtra.org
Sat, 29 May 2004 10:31:05 +0200

I'm also having the same problem on suse9.1 using gecko-sharp 0.3.  I 
think I got a little further but I'm still not able to compile.  In 
gecko-sharp.pc, I had to change the Lib path from:




the dll's was also a dead link to the non-local mono path which I had to 

After changing those 2 things and doing a new ./configure I now get a 
little further but it stops with this error:

make[3]: Entering directory 
mcs /debug /out:MonoDevelop.exe /r:System.Drawing \
/r:../../../build/bin/MonoDevelop.Core.dll \
/r:../../../build/bin/MonoDevelop.Base.dll \
/define:GTK \
-r:glib-sharp -r:pango-sharp -r:atk-sharp -r:gdk-sharp -r:gtk-sharp 
-lib:/usr/lib/mono/gtk-sharp   \
-r:gnome-sharp -lib:/usr/lib/mono/gtk-sharp   \
././MonoDevelopMain.cs ././Dialogs/AddInTreeSettingsHandler.cs 
././Dialogs/ExceptionBox.cs ././AssemblyInfo.cs \
/resource:./../../../data/resources/SplashScreen.png,SplashScreen.png \
&& cp MonoDevelop.exe ../../../build/bin/.

** (/usr/lib/mono/1.0/mcs.exe:28752): WARNING **: Could not find 
assembly gecko-sharp, references from 
      Major/Minor: 1,0
      Build:       0,0
      Token:       de14aa3cf4f97add

Unhandled Exception: System.NullReferenceException: Object reference not 
set to an instance of an object
in (unmanaged) /usr/lib/libmono.so.0(mono_assembly_open+0x1b9) [0x4010496f]
in (unmanaged) /usr/lib/libmono.so.0 [0x400f4117]
in <0x000d1> Mono.CSharp.Driver:LoadAssembly (string,bool)
in <0x0009f> Mono.CSharp.Driver:LoadReferences ()
in <0x006ac> Mono.CSharp.Driver:MainDriver (string[])
in <0x0001a> Mono.CSharp.Driver:Main (string[])

Anyone have any ideas? Am I doing something wrong.

Does it matter if the -r flag uses the assemply name with or without the 
.dll extension? (I've tried it both ways in gecko-sharp.pc)

PS: Sorry about not staying in the thread, I just joined the list :)

Old message starts here::

Thanks Todd,
Tried this, still got the same problem, tried rebuilding on a clean install=
  and still no luck.  I'm using a VMWare image if this helps, but the 
l seems ok.

Any other ideas would be gratefully received

Todd Berman wrote:

Try installing gecko-sharp 0.3, you can get a link from the MD package
install tutorial.


On Wed, 2004-26-05 at 14:44 +0100, James Hurst wrote:
 > Hi all,=20
 > I've got mono beta 1 installed using Red Carpet on a SUSE 9.0 system.
 > On this I have built and installed:=20
 > gtksourceview-0.7.0=20
 > gtksourceview-sharp-0.2=20
 > gecko-sharp-0.2=20
 > And they seemed to build ok, and are present in the right places.
 > Monodevelop will now run through the './configure' processes fine,
 > however when I do 'make' I get the following error:=20
 > error CS0006: Cannot find assembly 'gecko-sharp.dll'
 >  I have checked the system, there is only one version of the file, the
 > gecko-sharp.pc file is in the PKG_CONFIG_PATH and seems to point to
 > the right place (educated guess more than actually know).
 > Hope people can shine light on the problem....=20
 > Thanks,=20
 > James Hurst