[MonoDevelop] Mac OS Error MonoDevelop (almost working)

Brian Gilman gilmanb@jforge.net
Sun, 8 Aug 2004 11:05:44 -0400

Hello all,

	After reading through some of the mailing lists, it looks like a lot  
of the Mac OS X users are getting the same error in monodevelop 0.5. It  
seems that you cannot run monodevelop outside its source directory. I  
have tried to run it inside the source directory and have gotten the  
following error:

	fuerte:~/monodevelop-0.5/build/bin gilmanb$ mono --debug  
Creating DefaultWorkbench
Loading error, please reinstall :
System.Reflection.TargetInvocationException: Exception has been thrown  
by the target of an invocation. ---> System.DllNotFoundException:  
in <0x000d4> (wrapper managed-to-native)  
MonoDevelop.Gui.Utils.Vfs:gnome_vfs_init ()
in <0x00014> MonoDevelop.Gui.Utils.Vfs:get_Initialized ()
in <0x00124> MonoDevelop.Gui.Widgets.FileBrowser:.ctor ()
in <0x00084> MonoDevelop.Gui.Pads.FileScout:.ctor ()
in (unmanaged) (wrapper managed-to-native)  
System.Reflection.MonoCMethod:InternalInvoke (object,object[])
in <0x0008c> (wrapper managed-to-native)  
System.Reflection.MonoCMethod:InternalInvoke (object,object[])
in <0x000f4> System.Reflection.MonoCMethod:Invoke  
--- End of inner exception stack trace ---

in <0x00168> System.Reflection.MonoCMethod:Invoke  
in <0x00060> System.Reflection.MonoCMethod:Invoke  
in <0x0006c> System.Reflection.ConstructorInfo:Invoke (object[])
in <0x001a4> System.Activator:CreateInstance (System.Type,bool)
in <0x00020> System.Activator:CreateInstance (System.Type)
in <0x00068> System.Reflection.Assembly:CreateInstance (string,bool)
in <0x00034> System.Reflection.Assembly:CreateInstance (string)
in <0x0016c> MonoDevelop.Core.AddIns.AddIn:CreateObject (string)
in <0x00060> MonoDevelop.Core.AddIns.Codons.ClassCodon:BuildItem  
in <0x00220>  
MonoDevelop.Core.AddIns.DefaultAddInTreeNode:BuildChildItems (object)
in <0x00098> MonoDevelop.Gui.DefaultWorkbench:UpdateViews  
in <0x0006c> MonoDevelop.Commands.InitializeWorkbenchCommand:Run ()
in <0x00760> MonoDevelop.SharpDevelopMain:Main (string[])

I have gnome-vfs 2.0 installed and upon running pkg-config  
--variable=libdir gnome-vfs-2.0 I get: /sw/lib (which is correct). How  
might I get better debugging information from monodevelop so I can  
really nail this bug down?


Brian Gilman
President Panther Informatics Inc.
9 Acadia Park #2
Somerville, MA 02143
Phone 617-335-8276 (Cell)
	   617-395-7916 (Lan)
E-Mail: gilmanb@pantherinformatics.com
AIM: gilmanb1

01000010 01101001 01101111
01001001 01101110 01100110
01101111 01110010 01101101
01100001 01110100 01101001
01100011 01101001 01100001

Confidentiality Notice

This transmission and the documents contained herein are confidential  
and privileged.  The transmission and the  documents are intended only  
for the individuals or entities named above.  If you are not the  
intended recipient, any disclosure, copying, distribution or use of  
this transmission is prohibited.  If you received this transmission in  
error, please contact us
immediately so that we may arrange for its return.