[MonoDevelop] Monodevelop not starting

Anders Rune Jensen arj@cs.auc.dk
Fri, 2 Apr 2004 10:05:59 +0200


I've gotten Monodevelop 0.2 installed but when I try to start it I hit an

Complete errormessage:

node `debugger' is not defined on the documentation map
Creating DefaultWorkbench
Tools: can't load user defaults, reading system defaults

(MonoDevelop:7973): GLib-GObject-CRITICAL **: file genums.c: line 394
(g_value_set_enum): assertion `G_VALUE_HOLDS_ENUM (value)' failed

Unhandled Exception: System.NullReferenceException: A null value was found where
an object instance was required.
in (unmanaged) (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00004> (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00007> Gtk.Application:Run ()
in [0x0000a] (at
MonoDevelop.Commands.StartWorkbenchCommand:Run ()
in [0x001c1] (at
MonoDevelop.SharpDevelopMain:Main (string[])

/usr/bin/monodevelop: line 40:  7973 Segmentation fault      mono --debug
./MonoDevelop.exe $@

I have compiled Monodevelop with all dependencies. I tried to compile it without
the debugger but there doesn't seem to be a switch for that in the configure.

I tried to get a trace but I didn't have enough free space left (I stopped it at
2.5G) ;)

Also monodevelop --version reports Gnome MonoDevelop 0.1 ;)

Anders Rune Jensen