[Monodevelop-devel] Can't get monodevelop to show GTK# 2.00 under C# heading

Michael Hutchinson m.j.hutchinson at gmail.com
Wed Nov 5 20:08:01 EST 2008

On Sun, Oct 26, 2008 at 8:00 PM, Justin Weber <embed68k at dejazzd.com> wrote:
> I've been trying like hell to get GTK# 2.0 to show under the C# heading under
> new solution. I downloaded and installed Xcode from apple.com. I go into the
> add-in manager in monodevelop and it complains about not being able to find
> gtkcore 1.9.0 in the go-mono repository. I've tried every thing I could
> think of and searched forever to do this, but still I can't succeed. I've
> also tried getting a c# heading to appear in Xcode and followed the
> tutorials for moving the csharp plugin file, that doesn't work either. This
> is apple, it's not supposed to be this hard. Is it??

The GTK# addin isn't included in the Mac builds, because drag-n-drop
issues in the Mac GTK prevent our GTK# designer from working on Mac.
Unfortunately the GTK# templates are in the same addin as the
designer. However, handwritten GTK# code should still work -- MD
itself uses GTK#.

BTW, monodevelop-devel-list is for discussing the code/development of
MonoDevelop. For other discussions, including bugs and support, please
use monodevelop-list.

Michael Hutchinson

More information about the Monodevelop-devel-list mailing list