[Mono-winforms-list] stuck with WinForms issue, not sure how to proceed

Frank Bergmann fbergman at caltech.edu
Thu Jun 19 19:43:00 UTC 2014

Try running your assembly like this: 

MONO_LOG_LEVEL=debug mono --trace TestJemForms.exe

this sets the MONO_LOG_LEVEL environment variable to debug, so you see what native libraries are loaded. Adding the —trace option will let you see what is being executed. (You could even add filtering there by namespace, so you see only things that are interesting to you). 

for me your assembly ultimately crashed, as it was looking for some resource not bundled in your archive: 

[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Images\group.ico
  at System.Drawing.Image.FromFile (System.String filename, Boolean useEmbeddedColorManagement) [0x00000] in <filename unknown>:0 


On Jun 19, 2014, at 8:10 PM, RhinoNY <ryan at ryanrogers.com> wrote:

> Hi there,
> I have a Windows Forms custom control assembly which I have authored that
> does not run under Mono and I’m stuck trying to figure out why.  I have
> provided a link to the testbed exe and the DLL below.  Both target Framework
> 2.0.  The DLL has a custom splitter, group bar, and navigation bar that I
> have authored.
> http://www.ryanrogers.com/monotest.zip
> I have ran both the DLL and EXE through Mono Analyzer and there were no
> issues found.  Of course, I make no p/invoke calls or anything like that.
> I have compiled under VS 2010 as well as Mono.  No warnings or errors
> compiling with either.  I used the CSC.exe syntax out from VS and ran it
> through the Mono compiler.
> However, it doesn’t matter whether I run the MS-compiled assemblies of the
> Mono-compiled assemblies.  In both cases I see a stack overflow warning
> (when run with –verbose), and the UI never launches.
> Everything runs fine using the MS runtime.
> I have tried both the “latest” and “stable” builds of Mono, and get the same
> result.
> I’m new too Mono, but a .Net veteran.  How do I get more info out of Mono so
> that I can tell what is causing the problem?  
> I know it’s my NavBar / GroupBar control that is causing the issue, as when
> I remove their creation from the testbed exe, it launches.  So something
> these controls are doing is causing an issue, but I have no idea what, and
> am not sure the best way to diagnose this using Visual Studio.  They are
> quite complex controls so I need some way to diagnose this.  Do I need to be
> running MonoDevelop?  Was hoping to avoid that...
> Are there some log files or logging options I'm overlooking?
> Any help or pointers would be most appreciated!
> Thanks,
> Ryan
> --
> View this message in context: http://mono.1490590.n4.nabble.com/stuck-with-WinForms-issue-not-sure-how-to-proceed-tp4663153.html
> Sent from the Mono - WinForms mailing list archive at Nabble.com.
> _______________________________________________
> Mono-winforms-list maillist  -  Mono-winforms-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-winforms-list

More information about the Mono-winforms-list mailing list