[Mono-winforms-list] TLS Invalid Certificate Error when connecting to WebService

GCHQ DNottingham at HASoftware.net
Thu Sep 29 10:56:44 EDT 2011

Attempting to debug a windows app in Mono produces this error when it
attempts to connect to the backend web service


I ran certmg --ssl mysite.com

It found the current certificate (X.509 v3) from Comodo (valid from
16/04/2010 to 30/05/2020) but also appended *** WARNING: Certificate
signature is INVALID ***

It still imported to the CA store and then displayed the company details
(CN=Our Organisation) valid from 16/01/2011 to 16/01/2012 and was
successfully imported into the AddressBook store

Still get the same error when attempting to debug the app in mono

Any ideas what to try next?


View this message in context: http://mono.1490590.n4.nabble.com/TLS-Invalid-Certificate-Error-when-connecting-to-WebService-tp3856100p3856100.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-winforms-list/attachments/20110929/08ce69c2/attachment-0001.html 

More information about the Mono-winforms-list mailing list