[Mono-winforms-list] Form doesn't show

Romain2 romain.puyfoulhoux at sfr.fr
Tue Feb 9 17:39:35 EST 2010


I tried a very simple sample like this on linux fedora 10:

public class Test
        static void Main() 
        {Application.Run(new Form());}

The program starts and doesn't stop, but the form is not shown. And I have
no exception. I tried the executable compiled on linux, by running it on MS
Windows and the form shows. I tried this :

MONO_LOG_LEVEL="debug" MONO_LOG_MASK="dll" mono MainForm.exe

and the outpout ends by this:

Mono-INFO: Searching for 'GdiplusStartup'.
Mono-INFO: Probing 'GdiplusStartup'.
Mono-INFO: Found as 'GdiplusStartup'.

Then after a while I had this :

Unhandled Exception: System.TypeInitializationException: An exception was
thrown by the type initializer for System.Windows.Forms.XplatUI --->
System.Net.Sockets.SocketException: Connection timed out
  at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP)
[0x00000] in <filename unknown>:0 
  at System.Windows.Forms.XplatUIX11.SetDisplay (IntPtr display_handle)
[0x00000] in <filename unknown>:0 
  at System.Windows.Forms.XplatUIX11..ctor () [0x00000] in <filename
  at System.Windows.Forms.XplatUIX11.GetInstance () [0x00000] in <filename
  at System.Windows.Forms.XplatUI..cctor () [0x00000] in <filename
  --- End of inner exception stack trace ---
  at System.Windows.Forms.Application.EnableVisualStyles () [0x00000] in
<filename unknown>:0 
  at VStyles.Form1.Main () [0x00000] in <filename unknown>:0 

Before I used mono installed with the rpm but now i use mono 2.2 that i
compiled from the sources but it's not better. Why i can't run a simple
program with winforms on linux ?

Thank you !
View this message in context: http://old.nabble.com/Form-doesn%27t-show-tp27508274p27508274.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.

More information about the Mono-winforms-list mailing list