[Mono-winforms-list] Compiling - package dotnet was not found

dominichamon dominic.hamon+nabble at stripysock.com
Sat Jun 20 18:20:05 EDT 2009

blindpigsaloon wrote:
> I recently installed Mono via the synaptic package manager on my Linux
> version Hardy Heron.  I'm able to compile and run the simple console app
> given as an example on the Mono Basics page.  However, when I try the
> Winforms 'Hello World' example, I get the following error:
> Package dotnet was not found in the pkg-config search path.  
> Perhaps you should add the directory containing 'dotnet.pc' 
> to the PKG_CONFIG_PATH environment variable
> No package 'dotnet' found
> error CS8027 Error running pkg-config.  Check the above output.

I was getting exactly the same error on Mac OS X. I fixed it by adding the
/Library/Frameworks/Mono.framework/Versions/2.4/lib/pkgconfig folder to the
PKG_CONFIG_PATH environment variable. Perhaps you can find dotnet.pc
elsewhere on your system by running:

find / -name dotnet.pc

View this message in context: http://www.nabble.com/Compiling---package-dotnet-was-not-found-tp17585297p24129810.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.

More information about the Mono-winforms-list mailing list