[Mono-winforms-list] Could not load file or assembly

elziko justin at elzik.co.uk
Thu Jan 8 09:04:59 EST 2009

I am trying to run a WinForms 'Hello World' application on the installation
of Mono that comes with Ubuntu.

The application is written & compiled in VB.NET in Visual Studio 2008
trageting the .NET Framework 2.0 on Windows. It consists of a single
start-up form containing a button. When the user clicks the button it causes
a simple 'Hello World' MessageBox to be shown.

However, when I try and run this using using Mono on Ubuntu I get:

** (Test Mono.exe:5810): WARNING **: Could not load file or assembly
'Microsoft.VisualBasic, Version=, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
The entry point method could not be loaded

After reading around I have tried doing the following:

"sudo apt-get install mono-winforms*"

But I still get the same error.

Can anyone help me get started so I can just run this simple application?


View this message in context: http://www.nabble.com/Could-not-load-file-or-assembly-tp21335169p21335169.html
Sent from the Mono - WinForms mailing list archive at Nabble.com.

More information about the Mono-winforms-list mailing list