[Mono-winforms-list] Running a MWF app on solaris

pablosantosluac at terra.es pablosantosluac at terra.es
Fri Dec 19 06:34:04 EST 2008


I'm trying to run a sample winforms app (just one form, the default app 
created by the vstudio wizard) on Solaris SPARC.

My mono is 2.0.1 as compiled by Steffen (in CC) -> basically a build on 
a solaris box.

That's what I get:

bash-3.00$ export MONO_THEME=nice
bash-3.00$ mono hello.exe
GLib: Cannot convert message: Conversion from character set 'UTF-8' to 
'646' is not supported

Unhandled Exception: System.TypeInitializationException: An exception 
was thrown by the type initializer for System.Windows.Forms.ThemeEngine 
---> System.ArgumentException: The requested FontFamily could not be 
found [GDI+ status: FontFamilyNotFound]
   at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000]
   at System.Drawing.FontFamily..ctor (GenericFontFamilies 
genericFamily) [0x00000]
   at (wrapper remoting-invoke-with-check) 
System.Drawing.FontFamily:.ctor (System.Drawing.Text.GenericFontFamilies)
   at System.Drawing.FontFamily.get_GenericSansSerif () [0x00000]
   at System.Windows.Forms.Theme..ctor () [0x00000]
   at System.Windows.Forms.ThemeWin32Classic..ctor () [0x00000]
   at System.Windows.Forms.ThemeEngine..cctor () [0x00000]
   --- End of inner exception stack trace ---
System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () 
   at System.Windows.Forms.Control..ctor () [0x00000]
   at System.Windows.Forms.ScrollableControl..ctor () [0x00000]
   at System.Windows.Forms.ContainerControl..ctor () [0x00000]
   at System.Windows.Forms.Form..ctor () [0x00000]
   at hello.Form1..ctor () [0x00000]
   at (wrapper remoting-invoke-with-check) hello.Form1:.ctor ()
   at hello.Form1.Main () [0x00000]

I tried with other mono-themes but I get the same result

Then, instead of a dummy app I'm trying to run the Plastic SCM GUI 
client, and it stops at:

ENTER:  (wrapper managed-to -native) System.Windows.Forms.X11Desktop 
Colors:gtk _init_check(intptr, intptr)(0, 0,)

It simply stops, no erros.

Any help would be appreciated.



More information about the Mono-winforms-list mailing list