[Mono-winforms-list] An annoying problem

Jonathan S. Chambers Jonathan.Chambers at ansys.com
Wed Jun 8 10:56:39 EDT 2005

I posted this and Miguel answered previously with a workaround (I don't
know about a fix). I put Miguel's answer below.


>      Sorry all, this is probably easy but I can't figure it out. I was

> running fine until I just updated from SVN (my source was maybe a week

> old). Now I get the following when I run a test app; obviously it  
> can't find the X11 lib. SWF apps were working prior to my updating  
> from SVN; did something change? I have libX11.so.6.2 in my  
> /usr/X11R6/lib/ directory, and that path is in my /etc/ld.so.conf file

> (if that provides any info).

I had the exact same issue, I had to edit my LD_LIBRARY_PATH to point to
/usr/X11R6/lib to make it work.

Am not sure why this is happening, I think the intention was to not
depend on the "-devel" packages which are the ones that ship the
version-less .so

In this process, someone forgot to test the code.

-----Original Message-----
From: mono-winforms-list-bounces at lists.ximian.com
[mailto:mono-winforms-list-bounces at lists.ximian.com] On Behalf Of Paul
Sent: Wednesday, June 08, 2005 10:40 AM
To: winforms
Subject: [Mono-winforms-list] An annoying problem


Whenever I try to run a program compiled against MWF, I keep getting the
same error

Unhandled Exception: System.TypeInitializationException: An exception
was thrown by the initializer for System.Windows.Forms.XplatUI --->
System.DllNotFoundException: libX11.so.6.2

I know this has come up before and from what I remember when Miguel
flagged it up was that there was a problem within XplatUI.

Is there a work around or will XplatUI be getting fixed sometime in the
not too distant future?


"He's not the Messiah, he's a very naughty boy"
- Life of Brian, Monty Python

Mono-winforms-list maillist  -  Mono-winforms-list at lists.ximian.com

More information about the Mono-winforms-list mailing list