[Mono-winforms-list] WinForms not working with simple program s

Peter Dennis Bartok Peter@mail.novonyx.com
Wed, 28 Jan 2004 12:47:44 -0700

It's being worked on. But there are some larger design things that need to =
be solved, that's why there's little visible progress.


-----Original Message-----
From: Jose Fuentes <JFuentes@classicfs.com>
To: "'mono-winforms-list@lists.ximian.com'" <mono-winforms-list@lists.ximia=
Date: Wed, 28 Jan 2004 10:17:29 -0500=20
Subject: RE: [Mono-winforms-list] WinForms not working with simple program =

I thought most of the system.windows namespace was un-done.

It would be nice if someone got it done, seems everyone only cares about we=
apps in the mono project.

Joe Fuentes

-----Original Message-----
From: Wayne Jensen [mailto:wayne@dogpoop.cjb.net]=20
Sent: Wednesday, January 28, 2004 2:51 AM
To: mono-winforms-list@lists.ximian.com
Subject: [Mono-winforms-list] WinForms not working with simple programs

The answer to my question is probably "RTFM"... but if it is, *please*=20
point me toward a manual that explains this.  I've been searching for=20
hours and can't find an answer.

I installed Mono from CVS and set up wine, following the instructions on=20
the Mono web site.  I successfully compiled a simple WinForms app using=20
mcs (one that I had previously run on .NET), then tried to run it with=20
Mono and had strange things happened.  I got errors saying
"err:menu:MENU_GetSysMenu failed to load system menu!"
a blank form was displayed, and a box popped up on top of that form that=20

"The application has produced an exception.  Press 'continue' if you=20
want the application to try to continue its execution.
An exception was thrown by the type initializer for System.Drawing.GDIPlus"

This box had three buttons (which appear to be blank until I click on=20
them): Stack Trace, Continue, Quit.  Clicking "Stack Trace" causes the=20
message "Control notification Code 0 Id =3D Hwnd 65595" to appear in the=20
console.  Clicking "Close" makes the form and the popup box go away, but=20
the app is still running in the console.  Clicking "Continue" makes the=20
popup go away, and another one appears saying "GdipCreateFromHDC" and=20
these messages appear in the console:

"err:menu:MENU_CopySysPopup Unable to load default system menu
err:menu:MENU_GetSysMenu failed to load system menu!
err:menu:MENU_CopySysPopup Unable to load default system menu
err:menu:MENU_GetSysMenu failed to load system menu!"

After hours of searching, the only thing I could think is that I was=20
using features that weren't implemented, so I downloaded this example=20
from the Mono wiki:


It did the same thing, except that instead of a blank form it had the=20
text boxes as shown in the screen shots (same error messages, same popup=20
on top of the form).

My system:
Red Hat Fedora Core 1
AMD Athlon XP
Mono from CVS
Wine from rpm mono-wine-20030318-1.ximian.6.1.i386.rpm

BTW, I'm able to run console "Hello World" apps just fine, but when I=20
try Gtk# or Gnome# apps I get "Unhandled Exception:=20
System.DllNotFoundException: libgtk-win32-2.0-0.dll" and "Unhandled 
Exception: System.DllNotFoundException: libgobject-2.0-0.dll"  I know 
this problem is OT for this list, but I just thought I'd include it just 
in case the problems were related.  When I tried fixing this, the only 
information I found said it was problems with /etc/mono/config, but I 
checked mine and it matches what the other postings I read said it 
should be.

Thanks in advance,

Mono-winforms-list maillist  -  Mono-winforms-list@lists.ximian.com
Mono-winforms-list maillist  -  Mono-winforms-list@lists.ximian.com