[Mono-winforms-list] Re: Help with Wine patched library on Linux

Paul Butcher paul.butcher@asa.co.uk
Thu, 31 Jul 2003 14:00:56 +0100

Thanks for the help - that got me some way further but still no window is 
showing.  I did the following

1.  win32server -p originally reported could not find libwin32.so - I realised 
/usr/local/lib was not in LD_LIBRARY_PATH.  With this corrected it runs OK.

2.  Then when I ran mono with example SWF app I got:
  Warning: no valid DOS drive found, check your configuration file.
  Warning: could not find wine config [Drive x] entry for current working
   directory ....; starting in windows directory.
  Invalid path L"c:\\windows" for L"windows" directory: does not exist
  Perhaps you have not properly edited or created your Wine configuration
  file. This is (supposed to be) '/people/paulb/.wine/config'

So I realised I had no valid .wine directory or config file.  I created a 
default one using my full wine build (an old one from 2001) together with the 
required fake_windows dir etc.

3.  Then on running mono I get instead:
  Warning: Language 'en_GB' was not found, retrying without country name...
  Warning: Language 'en' was not recognized, defaulting to English

and then the app hangs - no window appears but mono does not exit either.

How should wine be setup to run with these patched shared libs?

PS I meant SWF=1 in my original e-mail - just a typo!

Paul Butcher

On July 31st, 2003 rodolfocampero@hotmail.com wrote:
> Paul,
> Try executing
> $ win32server -p
> before calling your program (1.works for me; 2.don't remember the exact name 
> of the executable, look in <prefix>/bin).
> The environment variable is SWF.
>>From: Paul Butcher <paul.butcher@asa.co.uk>
>>Organization: ASA Ltd.
>>To: mono-winforms-list@lists.ximian.com
>>Date: Wed, 30 Jul 2003 17:23:37 +0100
>>Subject: [Mono-winforms-list] Help with Wine patched library on Linux
>>Having seen the patched wine libs were now on the mono download page I 
>>to finally try the System.Windows.Forms assembly, but I can't get it to 
>>Any help appreciated:
>>Here's what I've done:
>>1. Downloaded wine-20030318.tar.gz and patches from the wine patch site
>>(ibiblio) and built and installed according to instructions there.
>>(NB There is a source code error after patching in line 695 where a 
>>HMODULE module is declared after other statements which is not allowed in 
>>I swapped lines 694 and 695 to cure.)
>>2. Rebuilt mono-0.25 from sources (using my currently installed version 
>>an RPM caused mono errors finding the various wine .dll.so files)
>>3.  Built simple SWT example using mcs.
>>4.  Run using mono - reports the following and then EXITS leaving three
>>threads running and no window appears:
>>   MonoWin32: Initializing WineLib
>>I tried setting env var 'SWT=1' as suggested in some places but this made 
>>I notice the wine-patch archive includes patches to mono to build a monogui
>>stub - is this still required?  (I couldn't get it to build; automake
>>reported errors following instructions to patch mono)
>>My system is a SuSE 8.0 Linux with SMP kernel.
>>Paul Butcher
>>ALTON,Hants, England

This communication is confidential to the intended recipient(s). If you are not that person you are not permitted to make use of the information and you are requested to notify the sender immediately of its receipt then destroy the copy in your possession. Any views or opinions expressed are those of the originator and may not represent those of Advanced System Architectures Ltd.

*** This Email Has Been Virus Checked ***