[Mono-osx] OutputDataReceived event not raised when using the Process class together with Ffmpeg?

johot johan.otterud at gmail.com
Wed Jun 6 22:17:23 UTC 2012

Thank you very much for your sample efontana!

I tried using your sample with ffmpeg and unfortunately it did not work. It
however helped me reach some conclusions. First off all it seemed some data
where sent from ffmpeg using standard error output. The important data
however, which is the data about encoding progress comes in one big chunk
when the encoding has finished, also sent over standard error output. I
don't think there is a bug in mono here, maybe the output data don't have
the correct new line characters or something? I'm not sure... I'm going to
test this under Windows to see if I get the same result. At first I thought
everything was working when I started getting output, too bad I couldn't get
all of it, it's the progress data that is the most important one.

I also thought it worked at first because of the manual reset event code but
I tried uncomment it and got the same result, that is I get the first data
but it stops coming during encoding.

View this message in context: http://mono.1490590.n4.nabble.com/OutputDataReceived-event-not-raised-when-using-the-Process-class-together-with-Ffmpeg-tp4649705p4649762.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list