[Mono-osx] System.Text.Encoding.Default is empty

Bac joni.j.backstrom at gmail.com
Sat Jun 25 11:04:34 EDT 2011

I have been working on a gtk# project and in that project I'm using some
I came up with a problem when reading an xml-document.

/XmlDocument settingsDocument = new XmlDocument();
XmlElement root = settingsDocument.DocumentElement;
XmlNode searches = root.SelectSingleNode("Searches");/

On selecting single node it gives me an error. When figuring out what was
the cause for this error, I found out that SelectSingleNode uses
System.Text.Encoding.Default on somewhere and when Default is empty it
crashes. Tried that same code on linux and it worked well. So my question
is, why is System.Text.Encoding.Default empty and is there a way to fix

Oh, and the Mono version I am using is  2.8 (2.10.2 crashed too much, so I
really can't use it) and OSX 10.6.7.

View this message in context: http://mono.1490590.n4.nabble.com/System-Text-Encoding-Default-is-empty-tp3624674p3624674.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list