[Mono-osx] Cross-Thread Delegates.

Rodrigo Kumpera kumpera at gmail.com
Fri Jan 28 12:06:26 EST 2011

Can you please file a bug report with your example so
it doesn't get lost on mailing list archives.


On Tue, May 11, 2010 at 7:11 PM, MrDuncanM <mrduncanm at gmail.com> wrote:

> Hi All,
> I am trying to build a simple socket server for a personally project but
> when I run it on my mac it doesn't function. I wrote this once on the mac
> and could never get it to work. So I had some downtime at work and tried
> again in mono on a XP PC. Got it working great. Took it home and it
> wouldn't
> work, recompiling it on the mac didn't help.
> The problem seems to be that cross thread delegates are completely broken
> in
> mono on OSX. Maybe in Linux too, but I don't have access to a machine
> currently to try it out.
> I've attached the project in a zip file and would love some more insight
> into what's happening here. Maybe even some other way to accomplish the
> same
> goal.
> Thanks
> http://n4.nabble.com/file/n2174199/SocketServer.zip SocketServer.zip
> --
> View this message in context:
> http://mono.1490590.n4.nabble.com/Cross-Thread-Delegates-tp2174199p2174199.html
> Sent from the Mono - OSX mailing list archive at Nabble.com.
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-osx/attachments/20110128/e99e170e/attachment.html 

More information about the Mono-osx mailing list