[Mono-osx] How can a custom library be included in a package.

Geoff Norton gnorton at novell.com
Fri Feb 4 15:24:43 EST 2011

This is a bug in the latest addin.  We'll fix it in the next release, but for now you can work around it by installing mono 2.8.1


On 2011-02-04, at 3:03 PM, JasonZ wrote:

> I copy the executable to bin/Release/main.exe and MonoMac actually finds the
> executable and includes exactly those Mono libraries necessary, it just
> doesn't include my library... maybe if I copy my library to the bin/Release
> directory... I think I tried that.
> I also tried using "mmp" directly from the command line and it cannot find
> the proper version of MonoDevelop, even though it works fine within
> MonoDevelop:
> jason-zwolaks-macbook-pro:~ jzwolak$
> ./.config/MonoDevelop/addins/MonoDevelop.MonoMac. 
> dyld: Library not loaded:
> /Library/Frameworks/Mono.framework/Versions/2.8.1/lib/libmono-2.0.1.dylib
>  Referenced from:
> /Users/jzwolak/./.config/MonoDevelop/addins/MonoDevelop.MonoMac.
>  Reason: image not found
> Trace/BPT trap
> jason-zwolaks-macbook-pro:~ jzwolak$ ls
> /Library/Frameworks/Mono.framework/Versions/
> 2.8     2.8.2   Current
> -- 
> View this message in context: http://mono.1490590.n4.nabble.com/How-can-a-custom-library-be-included-in-a-package-tp3256437p3260929.html
> Sent from the Mono - OSX mailing list archive at Nabble.com.
> _______________________________________________
> Mono-osx mailing list
> Mono-osx at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-osx

More information about the Mono-osx mailing list