[Mono-osx] Mono 2.6.7 won't run on 10.4 -- libiconv version error

BesideTheVoid firstcomputer at gmail.com
Fri Sep 24 04:42:03 EDT 2010

I am using Mac OS X 10.4.11 on PowerPC.  The old Mono
(MonoFramework-2.4_7.macos10.novell.universal.dmg) worked fine for years.  I
uninstalled it using the script at http://www.mono-project.com/Mono:OSX then
installed MonoFramework-2.6.7_3.macos10.novell.universal.dmg and the pkg
installed without complaint.  However, now typing mono results in the
following error:

dyld: Library not loaded: /usr/lib/libiconv.2.dylib
  Referenced from: /usr/bin/mono
  Reason: Incompatible library version: mono requires version 7.0.0 or
later, but libiconv.2.dylib provides version 5.0.0
Trace/BPT trap

What I've tried so far:
-Installed macports, then typed
sudo port -v selfupdate
sudo port install libiconv
iconv --version
-output is:
iconv (GNU libiconv 1.13)
Copyright (C) 2000-2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Written by Bruno Haible.
-(libiconv used to be 1.11)
-I'm sure it updated the system's actual iconv, because for
whereis iconv
-output is:
but mono still produces the same error.

View this message in context: http://mono.1490590.n4.nabble.com/Mono-2-6-7-won-t-run-on-10-4-libiconv-version-error-tp2553199p2553199.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list