[Mono-osx] System.Drawing problems with Mono 2.8.1

Stifu stifu at free.fr
Sat Nov 20 06:15:36 EST 2010

This is a regression.

Geoff Norton replied to this, but for some reason his message doesn't appear
on the forum / nabble side of the mailing list at the moment, so I'm going
to repost what he said:

"It seems I introduced a regression, my apologies.

I've commited a fix in 14f0ab6 and uploaded a hotfix to:


Download that file and unzip its contents to:


and it should resolve the issue.

Please let me know if there are any further problems.


ChristianManthey wrote:
> Hi,
> i tried to run my application today with the current 2.8.1 framework on a
> G5 and encountered some strange errors in the Systems.Drawing.Bitmap
> class. After some tests i decided to upgrade my own MacBook from 2.6.7 to
> the new version and ran into the same error.
> Object reference not set to an instance of an object
>   at System.Drawing.Graphics.Dispose () [0x00000] in <filename unknown>:0
>   at (wrapper remoting-invoke-with-check) System.Drawing.Graphics:Dispose
> ()
>   at System.Drawing.Bitmap..ctor (System.Drawing.Image original, Int32
> width, Int32 height) [0x00000] in <filename unknown>:0
>   at (wrapper remoting-invoke-with-check) System.Drawing.Bitmap:.ctor
> (System.Drawing.Image,int,int)
> The function call was the following:
> newBitmap = new Bitmap(orgImage, iWidth, iHeight);
> This code is executed in a separate thread controlled by the main window
> thread.
> Now i tried to remove the 2.8.1 version (with the script from
> http://www.mono-project.com/Mono:OSX) and installed the old 2.6.7 version
> again, but now i do get a different error message...
> Generic Error [GDI+ status: GenericError]
>   at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in
> <filename unknown>:0
>   at System.Drawing.Image.Save (System.String filename,
> System.Drawing.Imaging.ImageCodecInfo encoder,
> System.Drawing.Imaging.EncoderParameters encoderParams) [0x00000] in
> <filename unknown>:0
>   at (wrapper remoting-invoke-with-check) System.Drawing.Image:Save
> (string,System.Drawing.Imaging.ImageCodecInfo,System.Drawing.Imaging.EncoderParameters)
> I also tried to use the 2.8 version but with no luck.
> Is there someone replaced with the 2.8.1 version that is not deleted with
> the script mentioned above and that is also not replaced with the 2.6.7
> version in the area of System.Drawing?
> Any help is highly appreciated!
> Kind regards,
> Christian

View this message in context: http://mono.1490590.n4.nabble.com/System-Drawing-problems-with-Mono-2-8-1-tp3050944p3051451.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list