[Mono-osx] Cross-Thread Delegates.

MrDuncanM mrduncanm at gmail.com
Tue May 11 13:11:58 EDT 2010

Hi All,

I am trying to build a simple socket server for a personally project but
when I run it on my mac it doesn't function. I wrote this once on the mac
and could never get it to work. So I had some downtime at work and tried
again in mono on a XP PC. Got it working great. Took it home and it wouldn't
work, recompiling it on the mac didn't help.

The problem seems to be that cross thread delegates are completely broken in
mono on OSX. Maybe in Linux too, but I don't have access to a machine
currently to try it out.

I've attached the project in a zip file and would love some more insight
into what's happening here. Maybe even some other way to accomplish the same


http://n4.nabble.com/file/n2174199/SocketServer.zip SocketServer.zip 
View this message in context: http://mono.1490590.n4.nabble.com/Cross-Thread-Delegates-tp2174199p2174199.html
Sent from the Mono - OSX mailing list archive at Nabble.com.

More information about the Mono-osx mailing list